Chinaunix首页 | 论坛 | 博客
  • 博客访问: 2915563
  • 博文数量: 355
  • 博客积分: 1241
  • 博客等级: 中尉
  • 技术积分: 4849
  • 用 户 组: 普通用户
  • 注册时间: 2011-01-27 06:48
个人简介

下死功夫,动活脑筋;读好书,交益友

文章分类

全部博文(355)

文章存档

2020年(6)

2019年(16)

2018年(23)

2017年(67)

2016年(42)

2015年(51)

2014年(57)

2013年(52)

2012年(35)

2011年(5)

分类: LINUX

2016-11-09 14:58:05

最近要用libkafka-asio,发现需要cmake 3.1,ubuntu 14.04自带的cmake版本居然是2.8.
本来想通过
sudo apt-get install software-properties-common
sudo add-apt-repository ppa:george-edison55/cmake-3.x
sudo apt-get update sudo apt-get install cmake 
但是发现**导致速度太慢,只好源码安装.
安装gtest
 
sudo apt-get install libgtest-dev
cd /usr/src/gtest
sudo cmake .
sudo make
sudo cp libg* /usr/lib/
 安装snappy

git clone git://github.com/trondn/snappy

cd snappy
cmake .
sudo make install

wget http://www.cmake.org/files/v3.4/cmake-3.4.1.tar.gz 
tar -xvzf cmake-3.4.1.tar.gz 
cd cmake-3.4.1/ 
./configure  
make
然后
sudo make install
sudo update-alternatives --install /usr/bin/cmake cmake /usr/local/bin/cmake 1 --force 
运行
cmake --version 
cmake version 3.4.1


CMake suite maintained and supported by Kitware (kitware.com/cmake). 
阅读(2372) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~