Chinaunix首页 | 论坛 | 博客
  • 博客访问: 2485097
  • 博文数量: 357
  • 博客积分: 1241
  • 博客等级: 中尉
  • 技术积分: 4864
  • 用 户 组: 普通用户
  • 注册时间: 2011-01-27 06:48
个人简介

下死功夫,动活脑筋;读好书,交益友

文章分类

全部博文(357)

文章存档

2019年(12)

2018年(23)

2017年(67)

2016年(45)

2015年(51)

2014年(58)

2013年(53)

2012年(42)

2011年(6)

分类: LINUX

2017-05-03 19:58:46

因为要安装matplotlib,发现apt安装需要一系列库,只好使用pip
发现同事的ubuntu安装了较新的版本libpng和freeetype
sunyao@sunyao-VirtualBox:~$ sudo apt-get install -f libpng-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libpng12-dev' instead of 'libpng-dev'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
 libpng12-dev : Depends: libpng12-0 (= 1.2.50-1ubuntu2) but 1.2.50-1ubuntu2.14.04.2 is to be installed
E: Unable to correct problems, you have held broken packages.




sudo apt-get install --reinstall libpng12-0=1.2.50-1ubuntu2


sudo apt-get install libfreetype6-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
 libfreetype6-dev : Depends: libfreetype6 (= 2.5.2-1ubuntu2) but 2.5.2-1ubuntu2.5 is to be installed
E: Unable to correct problems, you have held broken packages.




sudo apt-get install --reinstall libfreetype6=2.5.2-1ubuntu2
阅读(944) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~
评论热议
请登录后评论。

登录 注册