Chinaunix首页 | 论坛 | 博客
  • 博客访问: 871802
  • 博文数量: 87
  • 博客积分: 3324
  • 博客等级: 中校
  • 技术积分: 1003
  • 用 户 组: 普通用户
  • 注册时间: 2006-05-17 11:37
文章分类

全部博文(87)

文章存档

2014年(3)

2013年(5)

2012年(21)

2011年(13)

2010年(7)

2009年(9)

2008年(4)

2007年(14)

2006年(11)

分类: C/C++

2009-05-06 16:04:49

近日在Red Hat Enterprise Linux AS release 3 (Taroon Update 8)上安装一个程序,make的时候报出如下错误:
Can't locate object method "path" via package "Autom4te::Request" at /usr/bin/autom4te line 81

在google上查找,有的人说删除安装包目录内的autom4te.cache,可解决此问题,实际上还是无法解决该问题。

该问题是由于产生configure脚本的机器上的autoconf版本高于当前安装机器上的autoconf版本造成的。所以需要升级autoconf软件包。

升级方法为在Red Hat Enterprise Linux AS release 4的安装盘上获取
autoconf-2.59-5.noarch.rpm 

在安装机器上运行
rpm -U autoconf-2.59-5.noarch.rpm
即可完成升级。


注:先卸载低版本的autoconf,有问题,需要直接使用-U参数进行升级。
阅读(1346) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~