Chinaunix首页 | 论坛 | 博客
  • 博客访问: 3125545
  • 博文数量: 406
  • 博客积分: 10227
  • 博客等级: 上将
  • 技术积分: 9807
  • 用 户 组: 普通用户
  • 注册时间: 2009-04-17 21:48
个人简介

非淡泊无以明志,非宁静无以致远

文章存档

2020年(2)

2019年(5)

2018年(4)

2017年(3)

2016年(24)

2015年(8)

2014年(7)

2013年(3)

2012年(1)

2011年(23)

2010年(179)

2009年(147)

分类: 系统运维

2009-11-27 22:35:16

前言:无线接入点(AP)在无线网络中充当用户的中心通信点,可以连接有线和无线网络。使用Web浏览器和命令行接口(CLI)都可以完成配置。

一般来说,AP可以配置两个接口以太网接口和无线端口。

a:配置方式

    1:控制台端口(需要翻转线)

    2Telnet(远程登录)

    3Web浏览器(这是最简单的配置方法,只需要在图形界面(GUI)上就可以操作)

b:配置过程

    1:图形界面(GUI)根据IOS的不同,一般有两种基本的GUI界面。GUI配置简单这里就不说明了。

    2:通过TelnetMS-Dos中输入 Telnet ip-address

    3:使用CLI(命令行)配置是本文的重点。下面我将详细给大家说明。

首先连接物理线缆,打开超级终端(在系统“开始”菜单中的“通讯”中)。

超级终端的配置参数如下:

* 每秒比特数:9600

*数据位:8

*奇偶效验:无;

*停止位:1

*流控:Xon/Xoff或者无;

进入命令行的界面如下:

User Access Verification

Username: Cisco

Password:

Ap>show version     //可以查看当前版本信息

一:设置系统名

Ap>enable

Ap#config t

Ap(config)#hostname myap   //设置系统名,默认是ap

二:为BVI分配IP地址

AP连接到有线网络的时候,会自动创建一个BVI(网桥虚拟接口)连接到网络,允许所有端口都聚合在一个IP地址下。[说明一下我们只能在BVI接口上配置APIP地址,不能在其他接口]

Ap#config t

Ap(config)#interface bvi1   //进入BVI接口配置模式

Ap(config-if)#ip address address mask //第二个address为你分配的ip地址 mask为掩码

三:察看网络映射

Ap(config)#dot11 network-map 30 //要建立无线网络映射

Ap#show dot11 network-map //显示无线网络映射

Ap#show dot11 adjacent-ap //显示一个与某个AP邻连的AP列表

下面给大家一个示范:

Ap(config-if)#ip address 10.0.0.1 255.255.255.0

Ap(config-if)#ip address dhcp ?

Client-id Specify client-id to use

Hostname Specify value for hostname option

Ap(config-if)#ip address dhcp

关于启用和禁用接口的命令:shutdown 禁用 no shutdown 启用

四:配置SSID

SSID(服务集标示符)一个唯一的标识符,允许客户端识别出一个接入点(AP

Ap(config)#int dot11radio 0

Ap(config-if)#ssid myAP

Ap(config-if-ssid)#authentication open //设置认证类型

五:监控AP状态

Ap#show interface dot11radio 加上相应接口号

六:配置一些相应的服务

1Telnet/SSH

Ap(config)#line vty 0 4

Ap(config-line)#login local

Ap(config-line)#end

Ap#show run

!

line con 0

line vty 0 4

login local

line vty 5 15

login

!

end

2:热备份

备用设备位于它监控的AP附近,并且它的配置与被监控的设备相同。备用设备需要通过以太网和无线端口来监控AP。如果被监控的设备响应失败,那么备用AP将在线激活替换在网络中取代被监控的设备。

Ap(config)#iapp standby mac-address

Ap(config-if)#interface dot11radio 0

Ap(config-if)#ssid ssid-string

Ap(config-if)#infrastructure-ssid [optional]

Ap(config-if)#exit

Ap(config)#iapp standby poll-frequency seconds

Ap(config)#exit

Ap#show iapp standby-parms

3DNS

Ap(config)#ip domain-name sina.com

禁用域名查找

Ap(config)#no ip domain-lookup

4HTTP

下列命令可以为一个HTTP服务器提供安全性和改变默认帮助目录的配置

Ap(config)#ip http

Ap(config)#ip http authentication local

Ap(config)#ip http port 8080

Ap(config)#access-list 1 permit host 10.0.1.1

Ap(config)#ip http access-class 1

其他的例如:代理移动IPQos(服务质量), 网络时间协议,WDS(无线域服务)等的配置建议使用AP的图形界面来配置。

注意细节:

1:不能将直流电源同时连接到AP电源端口和内置电源。

2:绿色LED表示正常活动;黄色LED表示错误或者警告;红色LED表示AP没有正确运行或需要升级。

3:获得帮助输入?可以显示每种命令模式的可用命令列表。

4:在CLI下的常用编辑按键Return 向下滚动一行命令;Space向下滚动一屏命令;

Ctrl-D删除光标处的字符;Ctrl-Y从缓冲区中取出最近的一条目;

 

阅读(9876) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~