Chinaunix首页 | 论坛 | 博客
  • 博客访问: 2418509
  • 博文数量: 392
  • 博客积分: 7040
  • 博客等级: 少将
  • 技术积分: 4138
  • 用 户 组: 普通用户
  • 注册时间: 2009-06-17 13:03
个人简介

范德萨发而为

文章分类

全部博文(392)

文章存档

2017年(5)

2016年(19)

2015年(34)

2014年(14)

2013年(47)

2012年(40)

2011年(51)

2010年(137)

2009年(45)

分类:

2010-01-25 22:38:19

Building a Space Station
Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 1077
Accepted: 623

Description

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task.
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible.

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively.

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors.

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect.

Input

The input consists of multiple data sets. Each data set is given in the following format.

n
x1 y1 z1 r1
x2 y2 z2 r2
...
xn yn zn rn

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100.

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character.

Each of x, y, z and r is positive and is less than 100.0.

The end of the input is indicated by a line containing a zero.

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001.

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000.

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834

Source



题意描述:
三维空间,求最小生成树,两个球如果相交,则认为它们已连接(即距离为1),否则两个点的距离定义为它们球面之间的最短距离。

参照算法导论自己写的一个prim

#include <iomanip>
#include <iostream>
#include <cmath>
#include <string.h>
using namespace std;

#define MAX 0x7ffffff

typedef struct _node
{
    double x, y, z, r;
}ST_NODE;

ST_NODE nodes[110];
int n;
double map[110][110], key[110];
bool visited[110];

void map_build(int nb)
{
    int i;
    double c_x, c_y, c_z, c_r, p_x, p_y, p_z, p_r, dis;

    c_x = nodes[nb].x;
    c_y = nodes[nb].y;
    c_z = nodes[nb].z;
    c_r = nodes[nb].r;
    for (i=0 ; i<nb ; i++)
    {
        p_x = nodes[i].x;
        p_y = nodes[i].y;
        p_z = nodes[i].z;
        p_r = nodes[i].r;
        dis = sqrt((c_x - p_x) * (c_x - p_x) + (c_y - p_y) * (c_y - p_y) + (c_z - p_z) * (c_z - p_z));
        dis -= c_r + p_r;
        if (dis < 0.0)
            dis = 0.0;
        map[i][nb] = dis;
        map[nb][i] = dis;
    }
}

double extract_min()
{
    int i, min_idx;
    double min_path = (double)MAX;
    
    for (i=0 ; i<n ; i++)
    {
        if (!visited[i] && key[i] < min_path)
        {
            min_path = key[i];
            min_idx = i;
        }
    }

    return min_idx;
}

void init()
{
    int i;
    for (i=0 ; i<n ; i++)
        key[i] = (double)MAX;
    key[0] = 0.0;
}

double MST()
{
    int i, j, crt, next, min_idx;
    double sum;

    init();
    sum = 0.0;
    for (i=0 ; i<n ; i++)
    {

        /*抽取和已选节点集最近的一个未选节点*/
        min_idx = extract_min();

        /*sum是mst的长度*/
        sum += key[min_idx];

        /*标记当前节点已选*/
        visited[min_idx] = true;
        for (j=0 ; j<n ; j++)
        {

            /*修改与已选节点相邻的所有点的key值,用于extract_min()*/
            if (!visited[j] && key[j] > map[min_idx][j])
                key[j] = map[min_idx][j];
        }
    }

    return sum;
}

int main(int argc, char *argv[])
{
    double x, y, z, r, ret;
    int i;

    while ((cin >> n) && (0 != n))
    {
        memset(map, 0, sizeof(map));
        memset(visited, false, sizeof(visited));
        for (i=0 ; i<n ; i++)
        {
            cin >> nodes[i].x >> nodes[i].y >> nodes[i].z >> nodes[i].r;

            /*根据数据的球体数据建立邻接表*/
            map_build(i);
        }
        ret = MST();
        cout.setf(ios::fixed);
        cout << setprecision(3) << ret << endl;
    }
}


阅读(1333) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~