Chinaunix首页 | 论坛 | 博客
  • 博客访问: 276593
  • 博文数量: 61
  • 博客积分: 365
  • 博客等级: 一等列兵
  • 技术积分: 611
  • 用 户 组: 普通用户
  • 注册时间: 2009-12-04 11:39
文章分类

全部博文(61)

文章存档

2017年(15)

2016年(13)

2015年(19)

2014年(12)

2013年(2)

我的朋友

发布时间:2016-01-21 12:19:18

$# 是传给脚本的参数个数$0 是脚本本身的名字$1 是传递给该shell脚本的第一个参数$2 是传递给该shell脚本的第二个参数$@ 是传给脚本的所有参数的列表$* 是以一个单字符串显示所有向脚本传递的参数,与位置变量不同,参数可超过9个$$ 是脚本运行的当前进程ID号$? 是显示最后命.........【阅读全文】

阅读(691) | 评论(0) | 转发(0)

发布时间:2016-01-19 08:32:45

本文引用小马的博客,非原创,经验证,可行salt-api也用了一段时间了,现在从安装、配置、使用三个方面梳理下知识。1、安装采用pip安装方便快捷,当然编译安装也很nice。安装pip采用的编译安装的方式,版本当前最新1.5.6,下载、解压、编译、安装是不变的法则。[root.........【阅读全文】

阅读(1382) | 评论(0) | 转发(0)

发布时间:2015-12-30 18:40:38

一:安装部分:1、django我是使用pip直接安装的,pip install django==1.8.72、python安装,./configure --prefix=/usr/local/python2.7  --enable-shared  CFLAGS=-fPIC3、apache2.2,随便你怎么装(编译安装或者yum都可以),如果你是yum安装的话,请记得要把httpd-devel一起装了,不然找不到apxs不要怪我4.........【阅读全文】

阅读(1312) | 评论(0) | 转发(0)

发布时间:2015-12-30 14:33:12

安装mod_python,后,执行import mod_python报错:mod_python.so: undefined symbol: ap_my_generation问题修改源码中,src/Makefile文件LDLIBS=-lpython2.7 -lpthread -ldl  -lutil 改为:LDLIBS=-lpython2.7 -lpthread -ldl  -lutil -lm重新make clean,make,make install.........【阅读全文】

阅读(1835) | 评论(0) | 转发(0)

发布时间:2015-12-29 18:42:23

python 升级到2.7后,编译安装一些包的时候,会出现error: command 'gcc' failed with exit status 1之类的问题很多人会想到安装python-devel,但你yum安装的python-devel是2.6版本,而你的python已经升级到2.7版本,会出现找不到的情况所以,最简单的办法,就是把2.7版本下的include/python2.7放到/usr/include下.........【阅读全文】

阅读(1647) | 评论(0) | 转发(0)
给主人留下些什么吧!~~
留言热议
请登录后留言。

登录 注册