Chinaunix首页 | 论坛 | 博客
  • 博客访问: 279816
  • 博文数量: 61
  • 博客积分: 365
  • 博客等级: 一等列兵
  • 技术积分: 611
  • 用 户 组: 普通用户
  • 注册时间: 2009-12-04 11:39
文章分类

全部博文(61)

文章存档

2017年(15)

2016年(13)

2015年(19)

2014年(12)

2013年(2)

我的朋友

分类: LINUX

2015-12-22 17:36:14

错误:
libpython2.7.a: could not read symbols: Bad value

分析:网上很多说是python编译没加fPIC,经过我多次试验,发现可能有以下坑:
第一:存在libpython库,就是你python编译过多次,那么,请先把libpython2.7.so的动态链接库移动到其它地方
第二:libpython2.7.so的动态链接库不在默认路径下,找不到,这个可以放进去
第三:说是python源码中,要删除所有的.o文件,再编译安装

编译python:
./configure --prefix=/usr/local/python2.7  --enable-shared  CFLAGS=-fPIC

编译mod_wsgi
./configure --with-apxs=/soft/apache/bin/apxs --with-python=/usr/local/bin/python

总之一句话,升级python,各种坑等着你,新旧各种版本兼容问题,依赖问题,总之真的是 一言难尽
阅读(1304) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~