Chinaunix首页 | 论坛 | 博客
  • 博客访问: 1414574
  • 博文数量: 234
  • 博客积分: 4966
  • 博客等级: 上校
  • 技术积分: 3322
  • 用 户 组: 普通用户
  • 注册时间: 2006-11-13 01:03
文章分类

全部博文(234)

文章存档

2017年(2)

2016年(1)

2015年(8)

2014年(11)

2013年(44)

2012年(27)

2011年(22)

2010年(30)

2009年(37)

2008年(6)

2007年(45)

2006年(1)

分类: 系统运维

2013-06-13 15:02:45

很久没升级Gentoo了,心血来潮就升级一下,按操作手册,先emerge --sync一下
提示没有设置 gentoo profile,用命令eselest profile list ,的确显示没有选中profile,就eselect profile set 1
然后接着emerge --sync
有以下错误提示:

!!! Unable to parse profile: '/etc/make.profile'

!!! ParseError: Profile contains unsupported EAPI '5': '/usr/portage/profiles/eapi-5-files/eapi'

!!! Your current profile is invalid. If you have just changed your profile

!!! configuration, you should revert back to the previous configuration.

!!! Allowed actions are limited to --help, --info, --search, --sync, and

!!! --version.


网上逛了下,解决办法:

eselect profile set 0     #set 0 改 uclibc 库安装
emerge -u portage      #这一步是重新安装或升级安装portage都可
eselect profile set 1     #切换回正确的profile

参考:
http://www.ruiking.com//2013/eselect-profileqie-huan-wen-ti-gentoo/
http://v2yw.com/index.php/unable-to-parse-profile-etcmake-profile/

阅读(2565) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~