Chinaunix首页 | 论坛 | 博客
  • 博客访问: 309969
  • 博文数量: 111
  • 博客积分: 10
  • 博客等级: 民兵
  • 技术积分: 662
  • 用 户 组: 普通用户
  • 注册时间: 2011-02-20 07:22
个人简介

一步一个脚印

文章分类

全部博文(111)

文章存档

2019年(1)

2017年(2)

2016年(2)

2015年(6)

2014年(35)

2013年(65)

分类: LINUX

2013-06-02 09:28:13


如客户192.168.0.13没开机但已知其MAC,可在ROS上输入命令搞定:
/ip arp
add address=192.168.0.13 mac-address=00:15:F2:CF:F7:8A interface=LAN1 comment="" disabled=no
 

自动绑定

 

其实当网卡基于安装后默认的enabled时,会自动加入与ros相连接的网段的mac的地址对应数据 的。启用了REPLY-ONLY后非手动加入的就被阻挡于列表之外了。方法是手工加入或是在终端模式加copy或是整理好的数据 在粘贴加入,或是利用原来的导出数据,作导入处理。没加过一次就可以用脚本和指令实现批量加入,类似于批处理指令。
---------------------------------------------------------------------------------------------------
自动扫描加入ip-arp指令:
方式A:
:foreach i in=[/ip arp find dynamic=yes ] do=[/ip arp add copy-from=$i]
标准格式
方式B:
:foreach i in [/ip arp find dynamic yes ] do={/ip arp add copy-from $i} 
------------------------------------------------------------------------------------------------------------
自动删除指令:
:foreach i in [/ip arp find] do={/ip arp remove $i} 
标准格式为:
:foreach i in= [/ip arp find] do=[/ip arp remove $i]

命令行,取消arp 绑定

ip arp> /interface ethernet set LAN arp=disabled

阅读(1894) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~
评论热议
请登录后评论。

登录 注册