Chinaunix首页 | 论坛 | 博客
  • 博客访问: 6781190
  • 博文数量: 1662
  • 博客积分: 16831
  • 博客等级: 上将
  • 技术积分: 12554
  • 用 户 组: 普通用户
  • 注册时间: 2011-02-25 07:23
个人简介

柔中带刚,刚中带柔,淫荡中富含柔和,刚猛中荡漾风骚,无坚不摧,无孔不入!

文章分类

全部博文(1662)

文章存档

2021年(8)

2020年(24)

2019年(4)

2018年(19)

2017年(66)

2016年(60)

2015年(49)

2014年(201)

2013年(221)

2012年(638)

2011年(372)

分类: 云计算

2014-05-30 10:05:40

 

CloudStack + XenServer 部署 – 交换机配置和服务器连线(2).

分类: CloudStack 35人阅读 评论(0) 收藏 举报

   之前看了很多CloudStack的网络的资料,但是一直纠结于如何在物理机上连线,终于找的一个详细的文档。转载过来,等有物理服务器后进行部署.。

    文地址:

本文将根据设计文档, 对交换机进行配置和服务器网络连线方式进行说明.

Step1.交换机规划,  根据功能将交换机端口分为三个部分:

管理区域(交换机1 – 16 口):  用于XenServer和CloudStack的管理流量, 和VM 在主机间迁移产生的流量.

工作区域(交换机17 - 32 口):  用于VM之间访问和VM访问外部网络产生的网络流量.

存储区域(交换机33 – 48 口): 用于任何与存储交互数据流量.

Step2. 服务器连线.

根据设计服务器配置6块网卡, 其中网卡1, 3 ,5 分别连接到主交换机管理区域, 工作区域和存储区域. 网卡2, 4, 6 分别连接到备交换机管理区域, 工作区域和存储区域.

例如: 服务器XSR01S01网卡连线方式:

  • 第1块网卡连接到R01SW01交换机1口.
  • 第3块网卡连接到R01SW01交换机17口.
  • 第5块网卡连接到R01SW01交换机33口.
  • ———————————————-
  • 第2块网卡连接到R01SW02交换机17口.
  • 第4块网卡连接到R01SW02交换机17口.
  • 第6块网卡连接到R01SW02交换机33口.

连线比较简单,没有专门去画图。网上找了一张释义图,仅供参考。

Step3. 交换机配置(Cisco 3750x)

  • vlan 100
  • name CSManagement
  • exit
  • vlan 101
  • name Rack01Management
  • exit
  • vlan 102
  • name Rack02Management
  • exit
  • vlan 91
  • name publicVlan01
  • exit
  • vlan 92
  • name publicVlan02
  • exit
  • vlan 91
  • name publicVlan01
  • exit
  • vlan 92
  • name publicVlan02
  • exit

vlan接口配置 (在核心上配置)

  • interface vlan 100
  • ip address 172.16.100.1 255.255.255.0
  • exit
  • interface vlan 101
  • ip address 172.16.101.1 255.255.255.0
  • exit
  • interface vlan 102
  • ip address 172.16.102.1 255.255.255.0
  • exit
  • interface vlan 91
  • ip address 111.111.101.1 255.255.255.0
  • exit
  • interface vlan 92
  • ip address 111.111.101.1 255.255.255.0
  • exit

R01SW01交换机管理区域端口vlan配置

  • interface range gigabitEthernet 0/1 – 16
  • description Rack01Management
  • switchport mode access
  • switchport access vlan 101
  • exit

R01SW01交换机工作区域端口vlan配置

  • interface range gigabitEthernet 0/17 – 32
  • description Rack01Trunk
  • switchport mode trunk
  • switchport trunk encapsulation dot1q
  • switchport trunk allowed vlan all (or switchport trunk allowed vlan add 301 – 500, switchport trunk allowed vlan add 91)
  • exit

R01SW01交换机存储区域端口vlan配置

  • interface range gigabitEthernet 0/33 – 48
  • description Rack01Storage
  • switchport mode access
  • switchport access vlan 12
  • exit

 

阅读(252) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~