Chinaunix首页 | 论坛 | 博客
  • 博客访问: 4450559
  • 博文数量: 1648
  • 博客积分: 16831
  • 博客等级: 上将
  • 技术积分: 12484
  • 用 户 组: 普通用户
  • 注册时间: 2011-02-25 07:23
个人简介

柔中带刚,刚中带柔,淫荡中富含柔和,刚猛中荡漾风骚,无坚不摧,无孔不入!

文章分类

全部博文(1648)

文章存档

2019年(1)

2018年(20)

2017年(68)

2016年(61)

2015年(52)

2014年(204)

2013年(224)

2012年(645)

2011年(373)

分类: 网络与安全

2013-11-27 15:40:45

cisco 交换机最常用的命令(含恢复密码)
2012-03-12 14:36:57
标签:交换机 cisco 职场 休闲
原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。http://dngood.blog.51cto.com/446195/803637
?1 交换机基本状态: 
Switch:            //ROM状态 
Switch>            //用户模式  
Switch#            //特权模式  
Switch(config)#    // 全局配置模式  
Switch(config-if)# //接口状态   


 
2 交换机口令设置: 
Switch>enable                         //进入特权模式  
Switch#config terminal                //进入全局配置模式  
Switch(config)#hostname 1f            //设置交换机的主机名  
   
Switch(config)#enable password xxx    //设置特权非密口令  
Switch(config)#line console 0         //进入控制台口  
  
Switch(config-line)#line vty 0 4      //进入虚拟终端  
Switch(config-line)#login             //允许登录  
Switch(config-line)#password xxx      //设置登录口令xx  
Switch#exit                           //返回命令   


 
3 交换机VLAN设置: 
Switch#vlan database                        //进入VLAN设置  
Switch(vlan)#vlan 2                         //建VLAN 2  
Switch(vlan)#no vlan 2                      //删vlan 2  
Switch(config)#int g0/45                    //进入端口45 
Switch(config)#int range g0/1-10            //批量端口加入特定Vlan的命令,可选       
Switch(config-if-range)#                    //可选 
Switch(config-if)#Switchport access vlan 2  //当前端口加入vlan 2  
Switch(config-if)#Switchport mode trunk     //设置为trunk 模式  
Switch(config-if)#Switchport trunk allowed vlan 1,2 //设置允许的vlan  
Switch(config-if)#Switchport trunk encap dot1q //设置vlan 中继  
  


4 交换机设置IP地址: 
Switch(config)#interface vlan 1       //进入vlan 1  
Switch(config-if)#ip address x.x.x.x 255.255255.0         //设置IP地址  
Switch(config-if)#no shutdown         //开启   


 
5 交换机显示命令:  
Switch#show run                //查看当前配置信息  
Switch#show vlan               //查看vlan配置信息  
Switch#show interface          //查看端口信息  
Switch#show int g0/45          //查看指定端口信息  


 
6 交换机配置相关命令:
Switch#write                   //保存配置信息  
Switch#write erase             //write erase 清除启动配置 startup-config 
Switch#reload                  //重启 
System configuration has been modified. Save? [yes/no]: no //不保存  


 
7 启用snmp 
Switch>enable                  //进入特权模式  
Switch#configure terminal     //进入全局配置模式  
Switch(config)#snmp-server community dongnan ro 1 
                               //配置snmp团体字符并开启snmp代理服务 
Switch(config)#access-list 1 permit host 192.168.57.70 
                               //使用ACL限制只与特定主机进行SNMP协议交互 
Switch(config)# snmp-server community string [view view-name] [ro | rw] [access-list-number]  
Switch (config)#access-list access-list-number {deny | permit} source [source-wildcard]    
                               //关闭snmp: no snmp-server 
                               //删除团体字符: no snmp-server community string    
  
String: 团体口令字符(所有SNMP命令中只有设置团体口令的snmp-server community是必须的,其它的都是可选的.)  
View: view 可以用于限定哪些MIB分支不能用本community-string存取预先用snmp-server view定义 ro | rw 
                               //ro获得MIB对象信息     rw获得并可以修改MIB对象信息  
access-list-number:访问列表号  
  
   
Switch (config)#end             //回到特权模式  
Switch#show running-config     //查看配置  
Switch#copy running-config startup-config //保存配置  
 
扩展
cisco 口令恢复(以2960G为例)
交换机口令恢复的步骤  
1 串口线连接到到交换机的console口。  
2 先按住交换机面板上的mode键,然后打开电源。  
3 初始化flash。  
switch: flash_init  
4 更名含有password的配置文件。  
switch: rename flash:config.text flash:config.old  
5 启动交换机。  
switch: boot  
6 进入特权模式。  
Switch> enable  
7 此时开机是已忽略password,然后变更回来。  
Switch# rename flash:config.old flash:config.text  
8 copy配置文件到当前系统中。  
Switch# copy flash:config.text system:running-config  
9 査看口令。  
Switch# show run  (或者 show run | include password)
10 保存配置。  
Switch# write 
 
#add 2012 03 16
以太通道端口组(Ethernet Port Groups)
优点:1 带宽的可伸缩性 2 容错 3 负载均衡 4 对网络应用透明
举例:把交换机 A,B 的 1,2 号端口添加到同一个组 1 里面 
SwitchA# configure terminal 
SwitchA (config)# interface range gigabitethernet0/1 -2 
SwitchA (config-if-range)# switchport mode access 
SwitchA (config-if-range)# channel-group 1 mode ON 
SwitchA (config-if-range)# end 
 
SwitchB# configure terminal 
SwitchB(config)# interface range gigabitethernet0/1 -2 
SwitchB(config-if-range)# switchport mode access 
SwitchB(config-if-range)# channel-group 1 mode ON 
SwitchB(config-if-range)# end 


 
 
结束
更多欢迎到此讨论
71921660 
37275208 (已满)
 
本文出自 “dongnan” 博客,请务必保留此出处http://dngood.blog.51cto.com/446195/803637
阅读(663) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~
评论热议
请登录后评论。

登录 注册