Chinaunix首页 | 论坛 | 博客
  • 博客访问: 911528
  • 博文数量: 31
  • 博客积分: 10100
  • 博客等级: 上将
  • 技术积分: 1127
  • 用 户 组: 普通用户
  • 注册时间: 2006-04-29 09:16
文章分类

全部博文(31)

文章存档

2011年(1)

2010年(1)

2009年(13)

2008年(16)

分类: 系统运维

2009-09-11 10:31:31

              

丫丫网络

本博客地址:http://hi.baidu.com/52hack

 

详细CSICO VTP协议配置及实验()

20090802 星期日 上午 01:16

 

详细CSICO VTP协议配置及实验

实验名称 VTP配置

 

实验目的: 使其整个内部网络能够互相学习VTP协议实验要求:

 

1. 保证4台交换机能够学习到VTP协议

 

2. SW3交换机设置为透明模式且能够让其他交换机学习到VTP协议

 

3. SW3设置与其他交换属于不同的域并且其他交换机能够学习VTP协议;

 

实验拓扑

 

实验拓扑

 

 

实验步骤

 

S1配置:

 

Router>enable 进入特权模式

 

Router#config terminal

 

Enter configuration commands, one per line. End with CNTL/Z.

 

Router(config)#hostname s1 命名为S1

 

s1(config)#exit 退出

 

s1#vlan database 进入配置VLAN模式

 

s1(vlan)#vtp domain zixu vtp域名为zixu

 

s1(vlan)#vtp server vtp模式为server

 

s1(vlan)#vtp password zixu 密码为zixu

 

s1(vlan)#vtp v2-mode vtp版本号为2

 

s1(vlan)#vtp pruning 配置修建s1(vlan)#exit

 

s1#config terminal 全局模式

 

s1(config)#interface f0/0 进入指定的端口号

 

s1(config-if)#switchport mode trunk 0/0配置中继链路(trunk

 

s1(config-if)#no shut 激活模式

 

s1(config)#interface f0/14

 

s1(config-if)#switchport mode trunk

 

s1(config-if)#no shuts1(config-if)#exit

 

s1(config)#interface f0/15

 

s1(config-if)#switchport mode trunk

 

s1(config-if)#no shut

 

s1(config-if)#exits1(config)#exit

 

s1#vlan database

 

s1(vlan)#vlan 2 创建VLAN

 

s1(vlan)#vlan 3

 

s1(vlan)#vlan 4

 

s1(vlan)#exit

 

S2配置:

 

Router>enable

 

Router#config terminal

 

Router(config)#hostname s2

 

s2(config)#exits2#vlan database

 

s2(vlan)#vtp domain zixu 指定域名

 

s2(vlan)#vtp client 配置为客户机

 

s2(vlan)#vtp password zixu 制定密码zixu

 

s2(vlan)#vtp v2-mode 配置一致的版本V2

 

s2(vlan)#exits2#config terminal

 

s2(config)#interface f0/0

 

s2(config-if)#switchport mode trunk

 

s2(config-if)#no shut

 

s2(config-if)#exit

 

s2(config)#interface f0/14

 

s2(config-if)#switchport mode trunk

 

s2(config-if)#no shut

 

s2(config)#interface f0/15

 

s2(config-if)#switchport mode trunk

 

s2(config-if)#no shut

 

s2(config-if)#exit

 

s2(config)#interface f0/14

 

s2(config-if)#switchport mode trunk

 

s2(config-if)#no shut

 

s2(config-if)#exit

 

s2(config)#exit

 

s2#show vlan-switch

 

S3配置:Router>enableRouter#config terminal

 

Router(config)#hostname s3

 

s3(config)#exits3#vlan database

 

s3(vlan)#vtp domain zixu

 

s3(vlan)#vtp client

 

s3(vlan)#vtp password zixu

 

s3(vlan)#vtp v2-mode

 

s3(vlan)#exits3#config t

 

s3#config terminal

 

s3(config)#interface f0/14

 

s3(config-if)#switchport mode trunk

 

s3(config-if)#no shut

 

s3(config-if)#exit

 

s3(config)#interface f0/15

 

s3(config-if)#switchport mode trunk

 

s3(config-if)#no shut

 

s3(config-if)#no shutdown

 

s3(config-if)#exit

 

s3(config)#exit

 

s3#show vlan-switch

 

S4配置:

 

Router>enable

 

Router#config terminal

 

Router(config)#hostname s4

 

s4(config)#exits4#vlan database

 

s4(vlan)#vtp domain zixu

 

s4(vlan)#vtp client

 

s4(vlan)#vtp password zixu

 

s4(vlan)#vtp v2-modes4(vlan)#exit

 

s4#config terminal

 

s4(config)#interface f0/14

 

s4(config-if)#switchport mode trunk

 

s4(config-if)#no shuts4(config-if)#exit

 

s4(config)#interface f0/15

 

s4(config-if)#switchport mode trunk

 

s4(config-if)#no shut

 

s4(config-if)#exit

 

s4(config)#exit

 

s4#show vlan-switch

 

实验要求2只需在S3交换机上做以下配置,其中在SW1交换机中创建vlan ,在其他交换机中能否学习到;

 

s3#

 

s3#vlan database

 

s3(vlan)#vtp transparent 透明模式

 

s3(vlan)#exit

 

s3#show vlan-switch 查看vlan信息

 

实验要求3只需在S3交换机上做以下配置,其中在SW1交换机中创建vlan ,在其他交换机中能否学习到;

 

s3#

 

s3#vlan database

 

s3(vlan)#vtp domain qien 配置域名为qien

 

s3(vlan)#exits3#show vlan-switch

 

实验结果分析: 通过以上三个要求及实验步骤完全可以实现学习VTP协议及配置

 

实验结论: Vtp协议分为三种模式:serverclienttransparent

 

Server功能:可以创建、删除及修改vlan信息,可以学习及转发

 

Client功能:不可以创建、删除及修改vlan信息,可以学习及转发

 

Transparent功能:可以创建、删除及修改vlan信息(本地生效),可以转发,不学习其他VTP协议

 

VTP协议中有2种版本:v1v2V2支持不同域可以转发其他交换机的信息

 

查询结果










 

上一篇:保护账号安全 巨盾网游安全盾(...    下一篇:浅谈Eval解密之——工具篇2()

 

 

阅读(839) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~