Chinaunix首页 | 论坛 | 博客
  • 博客访问: 728736
  • 博文数量: 256
  • 博客积分: 3502
  • 博客等级: 中校
  • 技术积分: 3988
  • 用 户 组: 普通用户
  • 注册时间: 2012-04-17 21:13
文章分类

全部博文(256)

文章存档

2014年(11)

2013年(134)

2012年(111)

我的朋友

分类: 虚拟化

2012-05-16 19:13:12


1.静态 配置:

Router#sh run
Building configuration...

Current configuration : 791 bytes
!
version 12.4
no service password-encryption
!
hostname Router
!
!
!
!
!
ssh version 1
!
!
FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 202.115.100.1 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source static 192.168.10.2 202.115.100.2
ip nat inside source static 192.168.10.2 202.115.200.2
ip nat inside source static 192.168.10.3 202.115.200.3
ip nat inside source static 192.168.100.6 202.115.200.6
ip classless
!
!
!
ip dhcp excluded-address 192.168.10.1
!
ip dhcp pool sxsnyq
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 202.115.100.2
!
line con 0
line vty 0 4
login
!
!
end

 

2.动态nat (先清除route 配置)

Router#sh run
Building configuration...

Current configuration : 741 bytes
!
version 12.4
no service password-encryption
!
hostname Router
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 202.115.100.1 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip nat pool outpool 202.115.200.10 202.115.200.200 netmask 255.255.255.0
ip nat inside source list 1 pool outpool
ip classless
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.10.0 0.0.0.255
!
ip dhcp excluded-address 192.168.10.1
!
ip dhcp pool sxsnyq
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
!
line con 0
line vty 0 4
login
!
!
end

3.nat 重载pat

Router#sh run
Building configuration...

Current configuration : 644 bytes
!
version 12.4
no service password-encryption
!
hostname Router
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 202.115.100.1 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source list 1 interface FastEthernet0/1 overload
ip classless
!
!
access-list 1 permit 192.168.10.0 0.0.0.255
!
ip dhcp excluded-address 192.168.10.1
!
ip dhcp pool abc
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
!
line con 0
line vty 0 4
login
!
!
end
阅读(1416) | 评论(1) | 转发(0) |
给主人留下些什么吧!~~

十七岁的回忆2012-05-17 20:54:27

表示没有什么注释。。。