Chinaunix首页 | 论坛 | 博客
  • 博客访问: 261193
  • 博文数量: 54
  • 博客积分: 992
  • 博客等级: 大尉
  • 技术积分: 609
  • 用 户 组: 普通用户
  • 注册时间: 2011-04-12 20:40
文章分类

全部博文(54)

文章存档

2013年(1)

2012年(16)

2011年(37)

分类: LINUX

2012-11-21 17:26:25

1、[root@localhost etc]# rpm -qa|grep httpd,查看与httpd相关软件包。

httpd-tools-2.2.15-15.el6.centos.i686
httpd-2.2.15-15.el6.centos.i686

2、然后删除httpd:

[root@localhost etc]# rpm -e httpd

出现问题:

error: Failed dependencies:

httpd >= 2.2.0 is needed by (installed) gnome-user-share-0.10-6.el5.i386

3、还有一个相关的软件包没有删除,清除之,即:

[root@localhost etc]# rpm -e gnome-user-share

4、再删除httpd

[root@localhost etc]# rpm -e httpd

#可以使用参数–nodeps的意思就是不管各个程序包间的依赖关系。

[root@localhost etc]#rpm -e –nodeps httpd //这样不需要删除gnome-user-share了.

阅读(5559) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~