A+B for Input-Output Practice (VIII)
Problem Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
Sample Output
Author
lcy
Recommend
JGShining
程序代码:
- #include<stdio.h>
-
int main()
-
{
-
int i=0,t,n,k,j,count;
-
int sum=0;
-
int m[100];
-
-
scanf("%d",&n);
-
while(n--)
-
{
-
scanf("%d",&count);
-
for(k=0; k<count; k++)
-
{
-
scanf("%d",&t);
-
sum+=t;
-
}
-
m[i++]=sum;
-
sum=0;
-
}
-
for(j=0; j<i; j++)
-
{
-
if(j!=i-1)
-
printf("%d\n\n",m[j]);
-
else
-
printf("%d\n",m[j]);
-
}
-
-
return 0;
-
}
阅读(1590) | 评论(0) | 转发(0) |