A+B for Input-Output Practice (IV)
Problem Description
Your task is to Calculate the sum of some integers.
Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
Sample Input
Sample Output
Author
lcy
Recommend
JGShining
程序代码:
- #include<stdio.h>
-
int main()
-
{
-
int i,k,n,t;
-
int j=0;
-
int count=0,sum=0;
-
int m[100];
-
-
scanf("%d",&n);
-
while(n)
-
{
-
for(i=0; i<n; i++)
-
{
-
scanf("%d",&t);
-
sum+=t;
-
}
-
m[j++]=sum;
-
count++;
-
sum=0;
-
scanf("%d",&n);
-
}
-
-
for(k=0; k<count; k++)
-
{
-
printf("%d\n",m[k]);
-
}
-
return 0;
-
}
阅读(1635) | 评论(0) | 转发(0) |