Chinaunix首页 | 论坛 | 博客
  • 博客访问: 453811
  • 博文数量: 67
  • 博客积分: 2792
  • 博客等级: 少校
  • 技术积分: 1038
  • 用 户 组: 普通用户
  • 注册时间: 2010-03-13 19:00
文章分类

全部博文(67)

文章存档

2014年(2)

2013年(7)

2012年(1)

2011年(1)

2010年(56)

分类: LINUX

2010-07-10 11:48:56

    这两天在LAMP环境下搭建postfix邮件服务器时候出现了一个奇怪的问题,编译完postfix后postfix可以正常启动,然后就开始安装dovecot,安装中没有出现问题。但是在安装完之后生成配置文件,以及修改完配置文件,然后就创建PAM认证文件后启动dovecot时候出现了错误,错误日志如图:

经过在网上查询后最后终于查到了,原因是一个软件包“pam-devel"没装而导致的。。。。。。只要安装上这个软件包后就可以正常启动了,因为它的PAM认证出问题了才出现这个错误。当然是我个人观点,如有不对之处,还请谅解!!!建议在安装操作系统时候,把一些开发工具和一些库文件都安装上,不然在搭建服务时候会经常报错,不过能锻炼排错能力!!嘿嘿!!
阅读(2027) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~