Chinaunix首页 | 论坛 | 博客
  • 博客访问: 343095
  • 博文数量: 122
  • 博客积分: 5000
  • 博客等级: 大校
  • 技术积分: 1191
  • 用 户 组: 普通用户
  • 注册时间: 2009-10-24 11:12
文章分类

全部博文(122)

文章存档

2010年(122)

我的朋友

分类: C/C++

2010-04-18 13:49:29

一、问题描述

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21

85

789

0

Sample Output

21 0

85 5

789 62

二、解题思路

使用打表的方式求出所有的结果保存在num数组中。

 

三、代码

 

#include <iostream>
#include<math.h>
using namespace std;
const int N=250005;
const int iMax=1000001;
int d[N];//所有H number

int Hp[N];//所有H prime number

int num[iMax+1];//

//判断是否是 H prime

bool isHprime(int x)
{
    int i;
    int e=(int )sqrt(1.0 * x);
    if(x==1)
        return false;
    for(i=1;d[i]<=e;++i)
    {
        if(x%d[i]==0)
            return false;
    }
    return true;
}
void getNum(int n)
{
    int i,j;
    for(i=0;i<n;++i)
    {
        if(Hp[i]*Hp[i]>iMax)
            break;
        for(j=i;j<n;++j)
        {
            int temp;
            temp=Hp[i]*Hp[j];
            if(temp>iMax)
                break;
            else
            {
                if(num[temp]==0)
                    num[temp]++;
            }
        }
    }
    for(i=1;i<=iMax;++i)
    {
        num[i]+=num[i-1];
    }
}
int main()
{
    int i,j;
    memset(num,0,sizeof(num));
    //所有H number

    for(i=0;i<N;++i)
    {
        d[i]=4*i+1;
    }
    //求出所有Hprime

    for(i=0,j=0;i<N;++i)
    {
        if(isHprime(d[i]))
            Hp[j++]=d[i];
    }
    getNum(j);
    int x;
    while(scanf("%d",&x))
    {
        if(x==0)
            break;
        printf("%d %d\n",x,num[x]);
    }
    return 0;
}


阅读(759) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~