Chinaunix首页 | 论坛 | 博客
  • 博客访问: 343449
  • 博文数量: 122
  • 博客积分: 5000
  • 博客等级: 大校
  • 技术积分: 1191
  • 用 户 组: 普通用户
  • 注册时间: 2009-10-24 11:12
文章分类

全部博文(122)

文章存档

2010年(122)

我的朋友

分类: C/C++

2010-04-16 15:22:04

一、问题描述

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Sample Input

12

4873279

ITS-EASY

888-4567

3-10-10-10

888-GLOP

TUT-GLOP

967-11-11

310-GINO

F101010

888-1200

-4-8-7-3-2-7-9-

487-3279

Sample Output

310-1010 2

487-3279 4

888-4567 3

 

二、解题思路

电话号码是7位的,最多有1千万个,可以开一个1千万的数组作为哈希表。首先将输入转化为7位数字n,然后hash[n]++,最后扫描一下hash表,大于1的输出来即可,如果没有大于1的,则输出No duplicates.

三、代码

 

#include<iostream>
#include<stdlib.h>
#include<string>
using namespace std;
int hash[10000000];
char map[26]={'2','2','2','3','3','3','4','4','4','5','5','5','6','6','6','7','0','7','7','8','8','8','9','9','9','0'};
int main()
{
    int i,j,k;
    int N;
    char s[500];
    char num[30];
    int len;
    int xMin=10000000;
    int xMax=0;
    scanf("%d",&N);
    for(i=0;i<N;++i)
    {
        scanf("%s",s);
        len=strlen(s);
        for(j=0,k=0;j<len;j++)
        {
            if(s[j]>=48 && s[j]<=57)
                num[k++]=s[j];
            else
            {
                if(s[j]>=65 && s[j]<=90)
                    num[k++]=map[ s[j]-'A' ];
            }
        }
        num[k]='\0';
        int n=atoi(num);
        hash[n]++;
        if(xMax<n)
            xMax=n;
        if(xMin>n)
            xMin=n;
    }
    bool flag=false;
    for(i=xMin;i<=xMax;++i)
    {
        if(hash[i]>1)
        {
            int t1=i/10000;
            int t2=i%10000;
            if(t1<10)
                printf("00");
            else
            {
                if(t1<100)
                    printf("0");
            }
            printf("%d-",t1);
            if(t2<10)
            {
                printf("000");
            }
            else
            {
                if(t2<100)
                    printf("00");
                else
                    if(t2<1000)
                        printf("0");
            }
            printf("%d %d\n",i%10000,hash[i]);
            flag=true;
        }
    }
    if(flag==false)
        printf("No duplicates.\n");
    return 0;
}


阅读(1215) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~