Chinaunix首页 | 论坛 | 博客
  • 博客访问: 347724
  • 博文数量: 122
  • 博客积分: 5000
  • 博客等级: 大校
  • 技术积分: 1191
  • 用 户 组: 普通用户
  • 注册时间: 2009-10-24 11:12
文章分类

全部博文(122)

文章存档

2010年(122)

我的朋友

分类: C/C++

2010-04-14 20:07:08

一、问题描述

Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01

10

0010

0000

9

01

10

010

0000

9

Sample Output

Set 1 is immediately decodable

Set 2 is not immediately decodable

 

二、解题思想

使用Trie树。

三、代码

 

#include<iostream>
using namespace std;
struct trieNode
{
    int next[2];
    bool isword;
};
trieNode tt[2500];
int len;
int N=2500;
bool insert(char * tar)
{
    trieNode * p= & tt[0];
    while(*tar)
    {
        int id=*tar-'0';
        if(p->next[id]==-1)
        {
            p->next[id]=len;
            len++;
        }
        if(p->isword ==true)
            return false;
        p=&tt[ p->next[id] ];
        
        tar++;
    }
    p->isword=true;
    if(p->next[0]!=-1 || p->next[1]!=-1)
        return false;
    return true;
}
void clear(int n)
{
    for(int i=0;i<n;++i)
    {
        tt[i].isword=false;
        tt[i].next[0]=-1;
        tt[i].next[1]=-1;
    }
}
int main()
{
    int set=1;
    char str[15];
    clear(N);
    bool flag=false;
    bool decodable=true;
    len =1;
    while(scanf("%s",&str)!=EOF)
    {
        if(str[0]=='9')
        {
            if(decodable)
                cout<<"Set "<<set++<<" is immediately decodable"<<endl;
            clear(len);
            len =1;
            flag = false;
            decodable=true;
            continue;
        }
        if(flag)
            continue;
        if(insert(str)==false)
        {
            flag=true;
            decodable=false;
            cout<<"Set "<<set++<<" is not immediately decodable"<<endl;
        }    
    }
    return 0;

}


阅读(790) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~