Chinaunix首页 | 论坛 | 博客
  • 博客访问: 347728
  • 博文数量: 122
  • 博客积分: 5000
  • 博客等级: 大校
  • 技术积分: 1191
  • 用 户 组: 普通用户
  • 注册时间: 2009-10-24 11:12
文章分类

全部博文(122)

文章存档

2010年(122)

我的朋友

分类: C/C++

2010-04-14 13:49:24

一、问题描述

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2

3

911

97625999

91125426

5

113

12340

123440

12345

98346

Sample Output

NO

YES

 

二、解题思想

使用Trie树。将每一个电话号码插入到树中,如发现该号码前缀 已经出现在树中,或者该号码成为其他号码的前缀的话,即返回false,输入“NO”。如果全部号码播入后都没有返回false,则输出“YES”。

三、代码

 

#include<iostream>
using namespace std;
struct trieNode
{
    int next[10];
    bool isword;
};
trieNode Root;
int N=1000000;
trieNode tt[1000000];
int len;
bool insert(char * tar)
{
    trieNode * p= &tt[0];
    int id ;
    while(*tar)
    {
        id=*tar-'0';
        if(p->next[id]==-1)
        {
            p->next[id]=len;
            len++;
        }
        if(p->isword)
            return false;
        p=&tt[p->next[id]];
        tar++;
    }
    p->isword=true;
    for(int i=0;i<10;++i)
    {
        if(p->next[i]!=-1)
            return false;
    }
    return true;
}
void clear ( int n)
{
    for(int i=0;i<n;++i)
    {
        tt[i].isword=false;
        memset(tt[i].next,-1,sizeof(tt[i].next));
    }
}
int main()
{
    int c;
    int n;
    int i,j;
    char str[10005][15];
    scanf("%d",&c);
    clear(N);

    for(i=0;i<c;++i)
    {
        scanf("%d",&n);
        clear(len);
        len=1;
        bool flag=false;
        for(j=0;j<n;++j)
        {
            scanf("%s",&str[i]);
            if(flag)
                continue;
            if(insert(str[i])==false)
            {
                printf("NO\n");
                flag=true;
            }
        }
        if(!flag)
            printf("YES\n");
    }
    return 0;
}


阅读(1277) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~