Chinaunix首页 | 论坛 | 博客
  • 博客访问: 350638
  • 博文数量: 122
  • 博客积分: 5000
  • 博客等级: 大校
  • 技术积分: 1191
  • 用 户 组: 普通用户
  • 注册时间: 2009-10-24 11:12
文章分类

全部博文(122)

文章存档

2010年(122)

我的朋友

分类: C/C++

2010-03-30 15:23:30

一、问题描述

Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj.

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.

Sample Input

3

1 2

0 3

3 4

0

Sample Output

1 0 0

Hint

Huge input and output,scanf and printf is recommended.

 

二、解题思路

使用树状数组,将输入数据按E从小到大排序,如果E相同则按S从大到小排序。然后从后面往前遍历一次,计算比当前Cow更壮的Cow的数目。ES都相同时要特别处理。

三、代码

 

#include<algorithm>
using namespace std;
int C[100001];//树状数组

int Out[100001];//输出结果

int N;
struct P
{
    int S;
    int E;
    int index;
};
int cmp(const void * a,const void * b)
{
    P * c=(P *)a;
    P * d=(P *)b;
    if(c->E==d->E)
        return d->S - c->S;
    else
        return c->E - d->E;
}

int Lowbit(int x)
{
    return x&(x^(x-1));
}
void Modify(int i,int x)
{
    while(i<=N)
    {
        C[i]+=x;
        i+=Lowbit(i);
    }
}
int Sum(int n)
{
    int sum=0;
    while(n>0)
    {
        sum+=C[n];
        n-=Lowbit(n);
    }
    return sum;
}
P p[100001];
int main()
{
    int i;
    int n;
    scanf("%d",&n);
    while(n!=0)
    {
        int MAX=0;
        memset(C,0,sizeof(C));
        for(i=0;i<n;++i)
        {
            scanf("%d%d",&(p[i].S),&(p[i].E));
            p[i].S+=1;
            p[i].E+=1;
            p[i].index=i;
            if(MAX < p[i].E)
                MAX=p[i].E;
        }
        N=MAX;
        qsort(p,n,sizeof(p[0]),cmp);
        for(i=n-1;i>=0;--i)
        {
            if(i!=n-1 && p[i].E == p[i+1].E && p[i].S == p[i+1].S)
            {
                Out[p[i].index]=Out[p[i+1].index];
            }
            else
            {
                Out[p[i].index]=Sum(p[i].S);
            }
            Modify(p[i].S,1);
        }
        for(i=0;i<n;++i)
        {
            if(i!=0)
                printf(" ");
            printf("%d",Out[i]);
        }
        printf("\n");
        scanf("%d",&n);
    }
    return 0;
}


阅读(976) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~