Chinaunix首页 | 论坛 | 博客
  • 博客访问: 350665
  • 博文数量: 122
  • 博客积分: 5000
  • 博客等级: 大校
  • 技术积分: 1191
  • 用 户 组: 普通用户
  • 注册时间: 2009-10-24 11:12
文章分类

全部博文(122)

文章存档

2010年(122)

我的朋友

分类: C/C++

2010-03-29 21:57:38

一、问题描述

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5

1 1

5 1

7 1

3 3

5 5

Sample Output

1

2

1

1

0

二、解题思路

这道题用常规的方法会超时,要使用线状数组。关于树状数组的知识参考其他资料,这里不再详细说明。C[i]为树状数组,i为星星的x坐标。Out[i]记录了leveli的星星个数。因为树状数组要求从1开始,故要对x坐标加1处理。按照已经排好序的输入顺序读入一个星星坐标并加1,即x=x+1,计算然后计算到目前为止,所有x坐标小于或等于x的星星个数sum。因为sum包含了当前星星,所以当前星星的level=sum-1,然后Out[level]++。最后输出Out数组元素。

三、代码

 

#include<algorithm>
#include<iostream>
using namespace std;
int C[32001];//数状数组
int Out[15001];//输出结果,Out[i]表示level i的星星个数
int N=32001;//星星个数
//计算x的二进制表示时后面有多少个0,即表示多个个元素的和
int Lowbit(int x)
{
    return x&(x^(x-1));
}
//修改树状数组,往原数组的i元素加x
void Modify(int i,int x)
{
    while(i<=N)
    {
        C[i]+=x;
        i+=Lowbit(i);
    }
}

int Sum(int n)
{
    int sum=0;
    while(n>0)
    {
        sum+=C[n];
        n-=Lowbit(n);
    }
    return sum;
}
int main()
{
    int n;
    scanf("%d",&n);
    
    int i;
    int x,y;
    for(i=1;i<=n;++i)
    {
        scanf("%d%d",&x,&y);
        x+=1;
        Modify(x,1);
        Out[Sum(x)-1]++;
    }
    for(i=0;i<n;++i)
        printf("%d\n",Out[i]);
    return 0;
}


阅读(1982) | 评论(0) | 转发(0) |
0

上一篇:全排列

下一篇:POJ 2481 Cows 解题报告

给主人留下些什么吧!~~