Chinaunix首页 | 论坛 | 博客
  • 博客访问: 227234
  • 博文数量: 32
  • 博客积分: 215
  • 博客等级: 入伍新兵
  • 技术积分: 936
  • 用 户 组: 普通用户
  • 注册时间: 2011-02-25 11:21
个人简介

一个靠社会发展推动我不懈努力的人!

文章分类

全部博文(32)

文章存档

2017年(3)

2016年(4)

2015年(8)

2013年(10)

2012年(7)

分类: PHP

2015-12-04 10:52:44

等保查出机器的PHP版本有高风险漏洞,需要升级。试了各种yum升级方式都没戏.具体为啥没戏就不一一说明了(可能你的环境可以)
我的是centos 7.1系统

卸载重装方式:(安全)
CentOS/RHEL 7.x:
rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

CentOS/RHEL 6.x:
rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm
Now you can install PHP 5.6 (along with an opcode cache) by doing:


yum install php56w php56w-opcache


直接升级:(有风险)
yum install yum-plugin-replace 
yum replace php-common --replace-with=php56w-common
yum install php56w-opcache
阅读(2038) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~