Chinaunix首页 | 论坛 | 博客
  • 博客访问: 2418542
  • 博文数量: 392
  • 博客积分: 7040
  • 博客等级: 少将
  • 技术积分: 4138
  • 用 户 组: 普通用户
  • 注册时间: 2009-06-17 13:03
个人简介

范德萨发而为

文章分类

全部博文(392)

文章存档

2017年(5)

2016年(19)

2015年(34)

2014年(14)

2013年(47)

2012年(40)

2011年(51)

2010年(137)

2009年(45)

分类:

2009-12-03 21:58:01

Common Subsequence
Submit: 407   Accepted:166
Time Limit: 1000MS  Memory Limit: 65536K
Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.


Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.


Sample Input

abcfbc abfcab
programming contest
abcd mnp


Sample Output

4
2
0



最长公共子序列

O(n^2)时间复杂度,DP

公式如下,其中A,B表示两个字符串,c[i][j]存储的是中间结果

c[i][j]=0,                         i=0,j=0
c[i][j]=c[i-1][j-1]+1,             A[i]==B[j]
c[i][j]=max(c[i-1][j],c[i][]j-1)   A[i]!=B[j]

c[strlen(A)][strlen(B)]即为LCS的结果



http://blog.csdn.net/fangxia722/archive/2008/10/10/3051524.aspx

代码:

#include <stdio.h>
#include <string.h>

#define MAX(a, b) ((a) > (b) ? (a) : (b))

char A[1000], B[1000];
int dp[1000][1000];

int LCS(char *a, char *b, int a_len, int b_len)
{
    int i, j;
    for (i=1 ; i<=a_len ; i++)
    {
        for (j=1 ; j<=b_len ; j++)
        {
            if (a[i-1] == b[j-1])
            {
                dp[i][j] = dp[i-1][j-1] + 1;
            }
            else
            {
                dp[i][j] = MAX(dp[i-1][j], dp[i][j-1]);
            }
        }
    }
    return dp[a_len][b_len];
}

int main(int argc, char *argv[])
{
    while (EOF != scanf("%s%s", A, B))
    {
        printf("%d\n", LCS(A, B, strlen(A), strlen(B)));
    }
}


阅读(718) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~