Common Subsequence
Time Limit: 1000MS |
| Memory Limit: 10000K |
Total Submissions: 15634 |
| Accepted: 6055 |
Description
A
subsequence of a given sequence is the given sequence with some
elements (possible none) left out. Given a sequence X = < x1, x2,
..., xm > another sequence Z = < z1, z2, ..., zk > is a
subsequence of X if there exists a strictly increasing sequence <
i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij
= zj. For example, Z = < a, b, f, c > is a subsequence of X =
< a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >.
Given two sequences X and Y the problem is to find the length of the
maximum-length common subsequence of X and Y.
Input
The
program input is from the std input. Each data set in the input
contains two strings representing the given sequences. The sequences
are separated by any number of white spaces. The input data are correct.
Output
For
each set of data the program prints on the standard output the length
of the maximum-length common subsequence from the beginning of a
separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
LCS:
问题描述
给定两个序列
X = { x1 , x2 , ... , xm }
Y = { y1 , y2 , ... , yn }
求X和Y的一个最长公共子序列
举例
X = { a , b , c , b , d , a , b }
Y = { b , d , c , a , b , a }
最长公共子序列为
LSC = { b , c , b , a }
二 问题分析
分析:
最长公共子序列问题具有最优子结构性质
设
X = { x1 , ... , xm }
Y = { y1 , ... , yn }
及它们的最长子序列
Z = { z1 , ... , zk }
则
1、若 xm = yn , 则 zk = xm = yn,且Z[k-1] 是 X[m-1] 和 Y[n-1] 的最长公共子序列
2、若 xm != yn ,且 zk != xm , 则 Z 是 X[m-1] 和 Y 的最长公共子序列
3、若 xm != yn , 且 zk != yn , 则 Z 是 Y[n-1] 和 X 的最长公共子序列
由性质导出子问题的递归结构
当 i = 0 , j = 0 时 , c[i][j] = 0
当 i , j > 0 ; xi = yi 时 , c[i][j] = c[i-1][j-1] + 1
当 i , j > 0 ; xi != yi 时 , c[i][j] = max { c[i][j-1] , c[i-1][j] }
该题的代码:
#include <stdio.h>
#include <string.h>
#define MAX(a, b) ((a) > (b) ? (a) : (b))
char A[1000], B[1000];
int dp[1000][1000];
int LCS(char *a, char *b, int a_len, int b_len)
{
memset(dp, 0, sizeof(dp));
int i, j;
for (i=1 ; i<=a_len ; i++)
{
for (j=1 ; j<=b_len ; j++)
{
if (a[i-1] == b[j-1])
{
dp[i][j] = dp[i-1][j-1] + 1;
}
else
{
dp[i][j] = MAX(dp[i-1][j], dp[i][j-1]);
}
}
}
return dp[a_len][b_len];
}
int main(int argc, char *argv[])
{
while (EOF != scanf("%s%s", A, B))
{
printf("%d\n", LCS(A, B, strlen(A), strlen(B)));
}
}
|
阅读(1380) | 评论(0) | 转发(0) |