Chinaunix首页 | 论坛 | 博客
  • 博客访问: 3709912
  • 博文数量: 356
  • 博客积分: 10458
  • 博客等级: 上将
  • 技术积分: 4734
  • 用 户 组: 普通用户
  • 注册时间: 2008-03-24 14:59
文章分类

全部博文(356)

文章存档

2020年(17)

2019年(9)

2018年(26)

2017年(5)

2016年(11)

2015年(20)

2014年(2)

2013年(17)

2012年(15)

2011年(4)

2010年(7)

2009年(14)

2008年(209)

分类: Python/Ruby

2020-05-30 13:27:09

使用keras,出错

Traceback (most recent call last):
 File "./real-time.py", line 8, in
   detect_hand = Detector(weights='weights/solo.h5', threshold=0.8)
 File "/home/zm/下载/Unified-Gesture-and-Fingertip-Detection/SOLO/solo.py", line 11, in __init__
   self.model = model()
 File "/home/zm/下载/Unified-Gesture-and-Fingertip-Detection/SOLO/model.py", line 9, in model
   x = Conv2D(1, (1, 1), activation='sigmoid')(x)
 File "/home/zm/tensor/lib/python3.6/site-packages/keras/engine/base_layer.py", line 446, in __call__
   previous_mask = _collect_previous_mask(inputs)
 File "/home/zm/tensor/lib/python3.6/site-packages/keras/engine/base_layer.py", line 1326, in _collect_previous_mask
   mask = node.output_masks[tensor_index]
AttributeError: 'Node' object has no attribute 'output_masks'

解决
查看tensorflow 及keras版本
import tensorflow as tf

>>> print(tf.__version__)
1.14.0
>>> import keras
Using TensorFlow backend.
>>> print(keras.__version__)
2.2.0
再到官网查看tensorflow及keras兼容版本关系
https://docs.floydhub.com/guides/environments/
发现tensorflow1.14.0对应的是keras2.2.5 ,于是手动升级keras到2.2.5
pip install --upgrade keras==2.2.5

作者:帅得不敢出门
阅读(129) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~