Chinaunix首页 | 论坛 | 博客
  • 博客访问: 4460997
  • 博文数量: 356
  • 博客积分: 10458
  • 博客等级: 上将
  • 技术积分: 4734
  • 用 户 组: 普通用户
  • 注册时间: 2008-03-24 14:59
文章分类

全部博文(356)

文章存档

2020年(17)

2019年(9)

2018年(26)

2017年(5)

2016年(11)

2015年(20)

2014年(2)

2013年(17)

2012年(15)

2011年(4)

2010年(7)

2009年(14)

2008年(209)

分类: C/C++

2017-05-02 22:07:45

Binary String Matching

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
描述 Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit 输入 The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A. 输出 For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A. 样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 

#include string.h
#include stdio.h

#define MAX_DATA_LEN 1000
#define MAX_VALUE_LEN 10

void BinaryStringMatching(char *data, char* value)
{
    int di;
    int vj;
    int matchTime = 0;
    int dataLen = strlen(data);
    int valueLen = strlen(value);

    for ( di = 0; di < dataLen; ++di )
    {
       for ( vj = 0; vj < valueLen; ++vj )
       {
            if (value[vj] != data[di+vj])
                break;
       }
       if (vj == valueLen) // match
       {
           ++matchTime;
       }
    }

    printf( "%d\n", matchTime );
}

    int
main( int argc, char **argv )
{
    char data[MAX_DATA_LEN];
    char value[MAX_VALUE_LEN];
    int dataLen;
    int valueLen;
    int i;
    int n;

    scanf("%d", &n);
    for ( i = 0; i < n; ++i )
    {
        scanf("%s", value);
        scanf("%s", data);
        BinaryStringMatching(data, value);
    }

    return 0;
}


阅读(1345) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~