Chinaunix首页 | 论坛 | 博客
  • 博客访问: 3878688
  • 博文数量: 356
  • 博客积分: 10458
  • 博客等级: 上将
  • 技术积分: 4734
  • 用 户 组: 普通用户
  • 注册时间: 2008-03-24 14:59
文章分类

全部博文(356)

文章存档

2020年(17)

2019年(9)

2018年(26)

2017年(5)

2016年(11)

2015年(20)

2014年(2)

2013年(17)

2012年(15)

2011年(4)

2010年(7)

2009年(14)

2008年(209)

分类: LINUX

2008-03-24 15:13:27

也弄这个弄了一天多的时间 终于可以了  也找了很多的资料  但由于是新手 遇到很多问题  还是要自己动手一

个一个的试过去  ,现在把自己的安装过程写下来与大家分享,当然资料参考网上也有一些是自己的体会的 由

于很多因素的影响也不一定适合你。但我希望能帮上点忙

下载 (最新版的mplayer支持的格式已经很多了解码器我安装我就不说了)

mplayer-20070814.tar.bz2 目前最新版 这个网上有下的

mplayer的skin和字体





安装基本编译器包含GCC make得 (build-essential)

#sudo apt-get install build-essential

解压:#tar -ixvf mplayer-20070814.tar.bz2

#cd mplayer-20070814

#./configure --enable-gui

出错:

Checking for inttypes.h (required) ... no

Checking for bitypes.h (inttypes.h predecessor) ...no

Error: Cannot find header either inttypes.h or bitypes.h (see DOCS/HTML/en/faq.h)

郁闷,估计又是什么开发库没有装,没办法google了下,看到网上有人说得装libc6-dev,装一个吧:

#sudo apt-get install libc6-dev

运行过程中安装了两个包:libc6-dev linux-kernel-headers

再次运行configure,又出错了:

Checking for GUI ... yes

Error: The GUI requires PNG support, please install libpng and libpng-dev packages.

Check "configure.log" if you do not understand why it failed.

我哭,这个也没有啊,dpkg了下,系统里面是有libpng的,但是没有libpng-dev,接着get吧:

#sudo apt-get install libpng12-dev

运行configure,再次出错,崩溃了.....

Error: X11 support required for GUI compilation.

去网上Google了下,需要GTK的dev包,继续get,我就不信了:

#sudo apt-get install libgtk1.2-dev

这会安装了15个包:

libglib1.2 libglib1.2-dev libgtk1.2 libgtk1.2-common libgtk1.2-dev libx11-dev libxau-dev libxdmcp-dev libxext-dev libxi-dev pkg-config x11proto-core-dev x11proto-input-dev x11proto-kb-dev x11proto-xext-dev

configure过后 就可以输入以下命令:

#make

#sudo make install

这样就会在/usr/local/mplayer/bin/下生成gmaplayer图形界面的 与mplayer命令行的

双击gmplayer无法运行 因为没有装默认皮肤

下载上面链接中的任意一个skin解压缩到/usr/local/share/mplayer/Skins目录下,记得一定要把其中一个skin的目录名改为default
比如你的皮肤为 xxx.tar.bz2
#tar jxvf xxx.tar.bz2
#sudo mv xxx /usr/local/share/mplayer/skins/
#cd /usr/local/share/mplayer/skins/
#sudo mv xxx default
安装字体:
# tar jxvf gb2312-kai.tar.bz2
#cd /usr/local/share/mplayer/
#sudo mkdir font
#cd ~
# cd gb2312-kai/gkai00mp16
# sudo cp * /usr/local/share/mplayer/font/
这样就可以运行gmplayer了  而且应用程序的音影中也有mplayer这个选项了  要看什么东东就尽力享受吧呵呵

我安装的是图形界面的mplayer
但是没有与视频关联    打开视频还是用默认的 啥也打不开的播放器打开
修改关联:
有时会遇到想默认用mplayer打开某种格式的影音文件,可以在该文件上点右键,选择”属性“->"打开方式”,点选“Mplayer movie player"(前面有黑点就是选上了),然后关闭”属性“对话框就可以了。
还有就是全屏问题了 :
播放时 点全屏后 画面还是原来那么小 只是框架最大化了
解决方法:
编辑 ~/.mplayer/config
加入一行zoom=yes
#sudo gedit ~/.mplayer/config
然后在里面加入一行
zoom=y
阅读(6079) | 评论(0) | 转发(0) |
0

上一篇:没有了

下一篇:[原]vector容器之冒泡排序

给主人留下些什么吧!~~