全部博文(102)
分类:
2010-12-27 16:28:33
Task 1 Select a pod number
Task 2 Erase the configuration from the router and switch module
Task 3 Perform basic router confiuration
Task 4 Configure the router switch module ports
Task 5 Verify the VLAN configuration
Task 6 Save the router configuration
the detail information is :
Task 1: select a pod number
Task 2: Erase the configuration from the Router and switch module
Router#delete flash:vlan.dat
Router#erase startup-config
Router# reload
Task 3: Perform Basic Router Configuration
Step 1: Router(config)#hostname RouterVoIPx
Step 2: RouterVoIPx# vlan database
Step 3: RouterVoIPx# vlan database
RouterVoIPx(vlan)#vlan x name Management state active
RouterVoIPx(vlan)#vlan x0 name Data State active
RouterVoIPx(vlan)#vlan x5 name Voice state active
RouterVoIPx(vlan)#interface vlan x
RouterVoIPx(config-if)#ip address 10.x.0.1 255.255.255.0
RouterVoIPx(config-if)#no shutdown
RouterVoIPx(config-if)#interface vlan x0
RouterVoIPx(config-if)#ip address 10.x0.0.1 255.255.255.0
RouterVoIPx(config-if)#no shutdown
RouterVoIPx(config-if)#interface vlan x5
RouterVoIPx(config-if)#ip address 10.x5.0.1 255.255.255.0
RouterVoIPx(config-if)#no shutdown
RouterVoIPx(config-if)#router eigrp 100
RouterVoIPx(config-router)#no shutdown
RouterVoIPx(config-router)#no auto-summary
Task 4: configuration the Router switch Module ports
RouterVoIPx#show diag
RouterVoIPx#show ip interface brief
(
1 Be configured in trunking mode
2 Have the IEEE802.1Q trunking protocol configured
3 Indetify the native VLAN
4 Identify the voice VLAN
)
RouterVoIPx(config)#interface fa0/0/0
RouterVoIPx(config-if)#switchport trunk encapsulation dot1q
RouterVoIPx(config-if)#switchport trunk native vlan x0
RouterVoIPx(config-if)#switchport mode trunk
RouterVoIPx(config-if)#switchport voice vlan x5
RouterVoIPx(config-if)#no shutdown
For example
Data :VLAN10 Voice :VLAN15
RouterVoIPx(config-if)#interface fa0/0/1
RouterVoIPx(config-if)#switchport trunk encapsulation dot1q
RouterVoIPx(config-if)#switchport trunk native vlan 10
RouterVoIPx(config-if)#switchport mode trunk
RouterVoIPx(config-if)#switchport voice vlan 15
RouterVoIPx(config-if)#no shut
Task 5: Verify VLAN configuration
RouterVoIPx#show interfaces fa0/0/0 switchport
RouterVoIPx#show interface trunk
RouterVoIPx#show ip interface briefTask: Save the Router Configuration
RouterVoIPx#copy running-config startup-config
RouterVoIPx(config)#interface fa0/0.x
RouterVoIPx(config-subif)#encapsulation dot1q x
RouterVoIPx(config-subif)#ip address 10.x.0.1 255.255.255.0
RouterVoIPx(config-subif)#interface fa0/0.x0
RouterVoIPx(config-subif)#ip address 10.x0.0.1 255.255.255.0
RouterVoIPx(config-subif)#encapsulation dot1q x0 native
RouterVoIPx(config-subif)#interface fa0/0.x5
RouterVoIPx(config-subif)#encapsulation dot1q
RouterVoIPx(config-subif)#ip address 10.x5.0.1 255.255.255.0
note:
The native keyword defines this VLAN as the one that is not tagged with VLAN information when e frame(from VLAN x0) crosses the trunk between the router and the switch.this allows the PC that connects to the IP Phone to be on a different subnet than the IP Phone and still receive an IP address from a DCHP Server.
RouterVoIPx(config-subif)#no shut
RouterVoIPx(config)#router eigrp 100
RouterVoIPx(config-router)#network 10.0.0.0
RouterVoIPx(config-router)#no auto-summary
RouterVoIPx(config-router)#do show ip interface brief
RouterVoIPx(config-router)#do copy run start
Task 6: Erase the switch
Switch#delete flash:vlan.dat
Switch#erase startup-config
Switch#reload
Task 7: Assign a switch name
Switch(config)#hostname SwitchVOIPx
Task 8: Configure Layer 3 Accesses to the Switch
SwitchVOIPx(config)#interface vlan x
SwitchVOIPx(config-if)#ip address 10.x.0.4 255.255.255.0
SwitchVOIPx(config-if)#description Management VLAN
SwitchVOIPx(config-if)#no shut
SwitchVOIPx(config-if)#ip default-gateway 10.x.0.1
Task 10: Confiure a Switch port as a Trunk Port
SwitchVOIPx(config-if)#interface fa0/1
SwitchVOIPx(config-if)#switchport trunk encapsulation dot1q
SwitchVOIPx(config-if)#switchport mode trunk
SwitchVOIPx(config-if)#switchport trunk native vlan x0--Data
SwitchVOIPx(config-if)#do show interface fa0/1 switchport
SwitchVOIPx(config-if)#do show interface trunk
Task11: Create VLAN on the Switch
SwitchVOIPx#vlan database
SwitchVOIPx(vlan)#vlan x name Management state active
SwitchVOIPx(vlan)#vlan x0 name Data state active
SwitchVOIPx(vlan)#vlan x5 name Voice state active
SwitchVOIPx(config-if)#do ping 10.x.0.1
SwitchVOIPx(config-if)#do ping 10.x0.0.1
SwitchVOIPx(config-if)#do ping 10.x5.0.1
Task 13: Configure Switch Ports for IP Phones
SwitchVOIPx(config-if)#interface fa0/2
SwitchVOIPx(config-if)#switchport trunk encapsulation dot1q
SwitchVOIPx(config-if)#swtichport mode trunk
SwitchVOIPx(config-if)#switchport voice vlan x5
SwitchVOIPx(config-if)#switchport trunk native vlan x0
SwitchVOIPx(config-if)#interface fa0/3
SwitchVOIPx(config-if)#switchport trunk encapsulation dot1q
SwitchVOIPx(config-if)#switchport mode trunk
SwitchVOIPx(config-if)#switchport voice vlan x5
SwitchVOIPx(config-if)#switchport trunk native vlan x0
SwitchVOIPx(config-if)#do copy run start