分类: 系统运维
2008-03-02 09:34:39
Lab 4.1 Configuring Frame Mode MPLS
I running this lab with GNS3 as following configure environment:
version: GNS3-0.3.1
Platform: Cisco-7200
System info: Intel core 2 Duo 2.4GH, 2GB memory
Topology:
step 1: start Router and change hostname
R0=R2, R1=R1, R2=R3
step 2: basic interface config and EIGRP
!
hostname R1
!
interface Loopback0
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.12.1 255.255.255.0
duplex half
!
router eigrp 1
network 172.16.0.0
no auto-summary
!
!
hostname R2
!
interface Loopback0
ip address 172.16.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.12.2 255.255.255.0
duplex half
!
interface Serial1/0
ip address 172.16.23.2 255.255.255.0
serial restart-delay 0
clock rate 64000
router eigrp 1
network 172.16.0.0
no auto-summary
!
hostname R3
!
!
interface Loopback0
ip address 172.16.3.1 255.255.255.0
!
interface Serial1/0
ip address 172.16.23.3 255.255.255.0
serial restart-delay 0
!
!
router eigrp 1
network 172.16.0.0
no auto-summary
!
Test:
step 3: view CEF status
show ip cef
setp 4: enable MPLS
GNS3 do not support mpls modal
dm!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Redo with Netlab as follow:
step 4: enable MPLS
R1(config)# interface fastethernet0/0
R1(config-if)# mpls ip
R2(config)# interface fastethernet0/0
R2(config-if)# mpls ip
R2(config-if)# interface serial0/0/1
R2(config-if)# mpls ip
R3(config)# interface serial0/0/1
R3(config-if)# mpls ip
sh mpls ldp dis:
sh mpls ldp nei
step 6:
R1(config)# interface fastethernet 0/0
R1(config-if)# mpls mtu 1508
sh run:
Building configuration...
Current configuration : 1093 bytes
!
! Last configuration change at 16:42:44 UTC Sat Mar 1 2008
! NVRAM config last updated at 16:20:45 UTC Sat Mar 1 2008
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 10
!
!
ip cef
!
!
no ip domain lookup
!
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.12.1 255.255.255.0
duplex auto
speed auto
mpls ip
mpls mtu 1508
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 125000
!
interface Serial0/0/1
no ip address
shutdown
!
router eigrp 1
network 172.16.0.0
no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end