Chinaunix首页 | 论坛 | 博客
  • 博客访问: 505811
  • 博文数量: 62
  • 博客积分: 2566
  • 博客等级: 少校
  • 技术积分: 520
  • 用 户 组: 普通用户
  • 注册时间: 2006-02-10 12:52
文章分类

全部博文(62)

文章存档

2008年(2)

2007年(22)

2006年(38)

我的朋友

分类: LINUX

2007-06-04 18:43:46

为方便修改,及大家查询本人的贴子,现把一部分规档如下目录索引:

---------------------------------------------------------------------------------------------------------------------
光纤及ADSL线路情况下的端口映射(实用的发布内网服务器www、FTP、mail)等服务器。



ROS菜单及对话框图示,汇总(实用、直观)



使用ROS自身的pppoe-server实现认证方式互联上网(内部局域网及外网似adsl)实用



使用ROS自身的vpn功能实现pptp l2tp加密互联异地网络(ros2.9.x)实用



ROS上网控制、IP与 MAC自动绑定上网、回流控制(光纤ip/adsl无ip)等更新于2006-7-27



3com公司的子网计算器工具正版(玩网络的和ros的必看)



Mikrotik 2.9.29 版发布了,只等3.0版了。2006-8-22




全面打造个性化的ros适用于2.7--2.9版本(其实那些商家的ros变种就这样做出来的)



排除VPN连接上后导致无法上网的故障




你的内网主机最好规划好,分段vlan管理,方便定时,及mac管理,当然根据你的实际 情况规则就可以了。

A、ROS成功实现时间段上网控制、
B、IP与
MAC
自动绑定上网、
C、回流控制(光纤ip/adsl无ip)在次讨论
D、图中有显示 说明是关于pcq网段限速的问题的。
E、双线时,自动换机问题
F、端口重定向 及ip重新转址功能(当然可以基于域名)。
G、关于 vpn的配置
H、关于pppoe-server的配置
I、关于hotspot热点计费类的配置
j、关于。。。。。。。。。。。。。还没想好写什么尼。呵呵
************************************************************

秋风答:
方法一:
关于议题内容”E、双线时,自动换机问题“:
a、第一个问题就是两百台机器在白天按100台机器走一条线,,另100台走另一条线..

b、第二个是晚上一条光纤停的时候怎么样能让所有的机器走另一条光纤线................

很好解决,第一做源地址标记分流,
第二个在路由表中换线备份处理(这类是早期版如2.7 2.8类的是这样的作法,相信大家都知了,在mange中加路由mark,就可以了,在走线时选你所打的mark来实现)  

秋风 2006-7-26更新

方法二:
关于
a、第一个问题就是两百台机器在白天按100台机器走一条线a,,另100台走另一条线b..

b、第二个是晚上一条光纤停的时候怎么样能让所有的机器走另一条光纤线................

其实方案二只是适用于2.9.x以上版本。主要是发挥它的在filter容器中的nat模块中的time组件。相信它是个
不错的组件,使用它的时间定时功能加入多条规则 实现来自不同的网段的主机或是子网掩码方式划分ip段来定时使内网主机 在不同时间走不同的接口,具体的方法请看下面的图示,其实很容易理解的。

    注意 :新建一条规则A
在time组件每天早上8:00到晚上6点其中100台主机ip段为192.168.0.1-192.168.0.100的内网的src-address中上网(nat或是叫ip伪装),在出口的out interface中选a一条线路。

              新建一条规则 B
在time组件每天早上8:00到晚上6点其中100台主机ip段为192.168.0.101-192.168.0.200的内网的src-address中上网(nat或是叫ip伪装),在出口的out interface中选另外b一条线路。
   
              新建一条规则C (如每天晚上18:10分-------早上8:10时一a条线断开)
在time组件每天晚上18:10分-------早上8:10把200台主机ip段为192.168.0.1-192.168.0.200的内网的src-address中打上(nat或是叫ip伪装),在出口的out interface中选另外b一条线路。(就是在这个时间全部内网主机从这条B线收发数据包)
   

方法三:
其实并不多,就是使用写脚本的方法人,修改源的ip段,代用时间控制定时触发器。来使用脚本生效的法子。不太详细说了。

总结:其实方法二是最简单的方法,方便的time组件模块extra下的time组件。大家可以灵活使用filter容器中的三件链的相关的time组件,包括queues模块中的time组件功能实现很多灵活的功能 。

秋风  2006-7-26 起草

***********************************************************
B、IP与 MAC自动绑定上网、
秋风答:

其实当网卡基于安装后默认的enabled时,会自动加入与ros相连接的网段的mac的地址对应数据 的。启用了REPLY-ON后非手动加入的就被阻挡于列表之外了。方法是手工加入或是在终端模式加copy或是整理好的数据 在粘贴加入,或是利用原来的导出数据,作导入处理。没加过一次就可以用脚本和指令实现批量加入,类似于批处理指令。
---------------------------------------------------------------------------------------------------
自动扫描加入ip-arp指令:
方式A: 标准格式

:foreach i in=[/ip arp find dynamic=yes ] do=[/ip arp add copy-from=$i]

方式B:
:foreach i in [/ip arp find dynamic yes ] do={/ip arp add copy-from $i}  
------------------------------------------------------------------------------------------------------------
自动删除指令:

方式A:
:foreach i in [/ip arp find] do={/ip arp remove $i}  

方式B:标准格式
:foreach i in= [/ip arp find] do=[/ip arp remove $i]
------------------------------------------------------------------------------------------------------------

对上面两个法子的补充:
就是说你的内网的主机的ip是通过ROS的dhcp-server的地址pool分发出的。其中在dhcp-server的一个选项中
有一个add arp for leases选项,只要选中它,从ros分发出的ip是可以自动帮定到ip-mac表中的,不让上网的计算机你就从中del掉对应的规则就可以了。这也是一个不错的方法。



秋风落叶扫      2006-7-27    广东中山


----------------------------------------------------------------------------------------------------------
关于问题A、定时上网

方法可以用脚本法不过不推荐大家使用,最简单的方法就是使用2.9的新加入的time组件
这规则 是可以灵活控制及使用的,你可以控制一个网段或是一个ip名是一个
mac
或是一个你定义的规则 。

请灵活使用。当然在新版的2.9.27中你可以控制 对于上传及下载的规则 (对于单独一个ip段及ip及
mac
作控制时也有个time组件。你一样可以实现定时段来控制了。

看图

AA、上传及下载时间段控制方法。看图。
秋风不断更新中...............................................

虽然ros商业化不能开源产品,但我们能做的是可以开源它的用法,它的教学!!!!!开源, 开源,再开源!!!!!!!--------------------------->>>>>linux debian  freebsd!!!!!!!!!!!!!

其实大家 用好ros中的time组件相信双线其策略路由类的,没什么可说的了,很方便的。

请把你知道的说出来,写出来,,,讲出来。。。。。。。。。。。。。


阅读(4315) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~