Chinaunix首页 | 论坛 | 博客
  • 博客访问: 279626
  • 博文数量: 61
  • 博客积分: 365
  • 博客等级: 一等列兵
  • 技术积分: 611
  • 用 户 组: 普通用户
  • 注册时间: 2009-12-04 11:39
文章分类

全部博文(61)

文章存档

2017年(15)

2016年(13)

2015年(19)

2014年(12)

2013年(2)

我的朋友

分类: Python/Ruby

2016-03-02 11:46:56

装cobber的时候遇到过这种问题,国内的资料几乎没有找到好的解决方案,看了一些国外的,试验了很多,最后发现了解决之道:
在cobber的安装目录下,说白了也是django的工程目录找到cobbler.wsgi,最后几行中
    import django.core.handlers.wsgi
    _application = django.core.handlers.wsgi.WSGIHandler()

修改为:

    from django.core.wsgi import get_wsgi_application
    _application = get_wsgi_application()

这个问题的原因,基本都是由于版本不匹配导致的,不过最终能解决,也是极好的!

阅读(2988) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~