Chinaunix首页 | 论坛 | 博客
  • 博客访问: 501535
  • 博文数量: 58
  • 博客积分: 6012
  • 博客等级: 准将
  • 技术积分: 1211
  • 用 户 组: 普通用户
  • 注册时间: 2007-08-09 22:50
文章分类

全部博文(58)

文章存档

2010年(25)

2009年(23)

2008年(10)

我的朋友

分类: 嵌入式

2009-12-17 22:31:45

平台:Ubuntu 9.04 桌面版 + XScales PXA270

--发现qte的后续版本是qt extend 4.4.3,但是再也没有生长了,诺基亚公司把qt改为交叉平台应用和图形借口架构(cross-platform application and UI framework),推出双授权的QT SDK,集成了友好的IDE.32位的linux平台的开发版可以从这里下载

# apt-get install libjpeg62-dev libjpeg62 libuuid1 libpng3 zlib1g
# su - cross_tool
$ wget ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-4.5.2.tar.bz2
$ mkdir -p qte/{source,target}
$ sudo mkdir /usr/local/qte
$ cd qte/source
$ tar -jxf ../../qt-embedded-linux-opensource-src-4.5.2.tar.bz2
$ cd ../target
$ ../source/configure -release -image /usr/local/qte -prefix /usr/local/qte -xplatform arm-xscale-linux-gnu-g++ -arch arm -no-qvfb -displaysize 1024x768 -no-modem -extra-qtopiacore-config "-release -xplatform qws/linux-mips-g++ -embedded arm -qconfig qpe -depths 8,16,32 " 2>../configure_error.log



阅读(1026) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~