Description
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure
1 shows a number triangle(三角形). Write a program that calculates the highest
sum of numbers passed on a route(路线) that starts at the top and ends
somewhere(某处) on the base. Each step can go either diagonally(角) down to the
left or diagonally down to the right.
Input
Your
program is to read from standard input. The first line contains one
integer N: the number of rows in the triangle. The following N lines
describe the data of the triangle. The number of rows in the triangle
is > 1 but <= 100. The numbers in the triangle, all integers, are
between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30
这个是经典的动态规划,也是最最基础、最最简单的动态规划,典型的多段图。
思路就是建立一个数组,由下向上动态规划,保存页子节点到当前节点的最大值。
#include <stdio.h>
int main(int argc, char **argv)
{
int n, i, j, max;
scanf("%d", &n);
getchar();
int a[n][n];
for(i = 0; i < n; i++){
for(j = 0; j <= i; j++){
scanf("%d", &a[i][j]);
}
getchar();
}
for(i = n-1; i >= 1; i--){
for(j = 0; j < i; j++){
max = (a[i][j] > a[i][j+1]) ? a[i][j] : a[i][j+1];
a[i-1][j] += max;
}
}
printf("%d\n", a[0][0]);
return 0;
}
|
阅读(1683) | 评论(0) | 转发(0) |