Ancient Cipher(密码)
Ancient Roman empire had a strong government system with various
departments, including a secret service department. Important documents
were sent between provinces and the capital in encrypted(加密) form to
prevent eavesdropping(窃听). The most popular ciphers in those times were so
called substitution(替换) cipher and permutation(置换) cipher.
Substitution cipher changes all occurrences of each letter to some
other letter. Substitutes for all letters must be different. For some
letters substitute letter may coincide with the original letter. For
example, applying substitution cipher that changes all letters from 'A'
to 'Y' to the next ones in the alphabet, and changes 'Z' to 'A', to the
message "VICTORIOUS" one gets the message "WJDUPSJPVT".
Permutation cipher applies some permutation to the letters of the
message. For example, applying the permutation <2, 1, 5, 4, 3, 7, 6,
10, 9, 8> to the message "VICTORIOUS" one gets the message
"IVOTCIRSUO".
It was quickly noticed that being applied separately, both
substitution cipher and permutation cipher were rather weak. But when
being combined, they were strong enough for those times. Thus, the most
important messages were first encrypted using substitution cipher, and
then the result was encrypted using permutation cipher. Encrypting the
message "VICTORIOUS" with the combination of the ciphers described
above one gets the message "JWPUDJSTVP".
Archeologists(考古学家) have recently found the message engraved(刻) on a stone
plate. At the first glance it seemed completely meaningless, so it was
suggested that the message was encrypted with some substitution and
permutation ciphers. They have conjectured(猜测) the possible text of the
original message that was encrypted, and now they want to check their
conjecture. They need a computer program to do it, so you have to write
one.
Input
Input contains
two lines. The first line contains the message engraved on the plate.
Before encrypting, all spaces and punctuation(标点符号) marks were removed, so
the encrypted message contains only capital letters of the English
alphabet. The second line contains the original message that is
conjectured to be encrypted in the message on the first line. It also
contains only capital letters of the English alphabet.
The lengths of both lines of the input are equal and do not exceed 100.
Output
Output
"YES" if the message on the first line of the input file could be the
result of encrypting the message on the second line, or "NO" in the
other case.
Sample Input
JWPUDJSTVP
VICTORIOUS
Sample Output
YES
#include <stdio.h>
char a[105], b[105];
int count_a[26], count_b[26];
int result_a[101], result_b[101];
int main(int argc, char **argv)
{
int i, pos_a, pos_b;
fgets(a, 105, stdin);
fgets(b, 105, stdin);
for(i = 0; a[i] != '\n'; i++){
pos_a = a[i] - 'A';
pos_b = b[i] - 'A';
count_a[pos_a]++;
count_b[pos_b]++;
}
for(i = 0; i < 26; i++){
if(count_a[i] != 0){
result_a[count_a[i]]++;
}
if(count_b[i] != 0){
result_b[count_b[i]]++;
}
}
for(i = 0; i < 101; i++){
if(result_a[i] != result_b[i]){
printf("NO\n");
return 0;
}
}
printf("YES\n");
return 0;
}
|
阅读(1907) | 评论(0) | 转发(0) |