Chinaunix首页 | 论坛 | 博客
  • 博客访问: 157257
  • 博文数量: 35
  • 博客积分: 2011
  • 博客等级: 大尉
  • 技术积分: 345
  • 用 户 组: 普通用户
  • 注册时间: 2009-03-09 21:36
文章存档

2010年(10)

2009年(25)

我的朋友

分类:

2010-12-23 13:11:42

Packets
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 28329Accepted: 9291

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

Source



//POJ_1017

#include <stdio.h>

int main(void)
{
    int a, b, c, d, e, f;
    int num;
    int empty_a;
    int empty_b;
    int u[4] = {0, 5, 3, 1};//map of C for B

    //freopen("e:\\test.txt", "r", stdin);

    while(1){
        scanf("%d%d%d%d%d%d", &a, &b, &c, &d, &e, &f);
        if(a==0 && b==0 && c==0 && d==0 && e==0 && f==0)
            break;

        num = f + e + d + (c+3)/4;//tips:(c+3)/4 is upper of c/4


        empty_b = 5*d + u[c%4];
        if(b>empty_b)
            num += (b-empty_b+8)/9;

        empty_a = 36*num - 36*f - 25*e - 16*d - 9*c - 4*b;
        if(a>empty_a)
            num += (a-empty_a+35)/36;

        printf("%d\n", num);
    }
    return 0;
}

注:不知道为什么提交C结果WA,提交GCC则是AC。
考虑4,5,6规格的产品都需要另开盒子,当考虑3规格的产品是比较复杂,需要一个map映射3规格的产品当前盒子剩余空间能放进几个2规格的产品,1规格的产品最后考虑,因为只要有空隙就可以往里插,可以利用总空间减去总是用空间来计算可以安插1规格产品的位置数目。
阅读(1727) | 评论(1) | 转发(0) |
0

上一篇:POJ_1012(Joseph)解题报告

下一篇:没有了

给主人留下些什么吧!~~

chinaunix网友2010-12-26 17:19:57

很好的, 收藏了 推荐一个博客,提供很多免费软件编程电子书下载: http://free-ebooks.appspot.com