Chinaunix首页 | 论坛 | 博客
  • 博客访问: 925242
  • 博文数量: 177
  • 博客积分: 761
  • 博客等级: 上士
  • 技术积分: 1518
  • 用 户 组: 普通用户
  • 注册时间: 2011-02-04 22:37
文章分类

全部博文(177)

文章存档

2017年(1)

2016年(3)

2015年(33)

2014年(48)

2013年(60)

2012年(32)

分类: LINUX

2012-08-03 17:00:25

       今天在ettus网上下载此版本来进行升级uhd_003.004.003-release_Ubuntu-10.04-x86_64,结果升级后发现
./uhd_usrp_probe
linux; GNU C version 4.6.3; Boost_104601; UHD_003.004.003-173-ga38e440b

-- Opening a USRP2/N-Series device...
Error: RuntimeError:
Please update the firmware and FPGA images for your device.
See the application notes for USRP2/N-Series for instructions.
Expected FPGA compatibility number 10, but got 9:
The FPGA build is not compatible with the host code build.
Please run:

sudo "/usr/local/share/uhd/utils/uhd_images_downloader.py"
"/usr/local/share/uhd/utils/usrp_n2xx_net_burner.py" \
    --fpga="/usr/local/share/uhd/images/usrp_n210_r4_fpga.bin" \
    --fw="/usr/local/share/uhd/images/usrp_n210_fw.bin" \
    --addr="192.168.10.3"
版本不匹配,我定你的肺,同一个文件下的fw和fpga印象竟然不匹配,为此我怀疑作者忘记改版本号了。接上一般本忘该了。于是乎升级回原来版本ok。还是用的gui升级...

另外有个新发现:
就是UHD
      USRP 后面的提示的字符是可以识别到了而不是usrp not implemented


阅读(3736) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~