Chinaunix首页 | 论坛 | 博客
  • 博客访问: 1824242
  • 博文数量: 116
  • 博客积分: 9934
  • 博客等级: 上将
  • 技术积分: 1881
  • 用 户 组: 普通用户
  • 注册时间: 2006-04-22 09:16
文章分类

全部博文(116)

文章存档

2007年(43)

2006年(73)

我的朋友

分类: 系统运维

2007-03-01 16:25:34

CISCO路由器连接ADSLPPPoE配置

姜道友

说明:

       很多公司使用ADSL宽带线路作为备份线路,同时作为内部上网的分流线路。这有两种配置:一种是cisco路由器连接ethernet接口连接ADSLmodem;一种是在cisco路由器上安装ADSL WIC卡,直接连接ADSL电话线。

 

Cisco路由器连接ADSL modemPPPoE配置:........................................................ 1

Cisco路由器连接ADSL WIC卡之PPPoE配置:........................................................ 3

 

路由器连接ADSL modemPPPoE配置:

 

hostname bjsite
!
ip subnet-zero
no ip domain-lookup
!
vpdn enable
no vpdn logging
!
vpdn-group 1
request-dialin
protocol pppoe
!
interface Ethernet0/0
ip address 192.168.0.1 255.255.255.0
ip nat inside
no ip mroute-cache
!
!
!
!
interface Ethernet0/1
no ip address
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
ip nat outside
ip mtu 1492
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
ppp authentication pap
ppp pap sent-username dg48907653@163.gd password xxxxxxxx
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 dialer1
access-list 1 permit 192.168.0.0 0.0.0.255
!
line con 0
exec-timeout 0 0
transport input none
line vty 0 4
login
!
end

 

路由器连接ADSL WIC卡之PPPoE配置:

vpdn-group pppoe
request-dialin

!--- we are the PPPoE client requesting to establish
!--- a session with the aggregation unit (6400 NRP).

protocol pppoe
!


!--- internal Ethernet network.

!
interface FastEthernet0
ip address 10.92.1.182 255.255.255.0
ip nat inside


!--- DSL interface.

!
interface ATM0
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
hold-queue 224 in

!--- All defaults.




!--- PPPoE runs on top of AAL5SNAP, but the
!--- encap aal5snap command is not used.

!
interface ATM0.1 point-to-point
pvc 1/1
pppoe-client dial-pool-number 1

!--- pvc 1/1 is an example value that must be changed
!--- to match the value used by the ISP.

!



!--- The PPPoE client code ties into a dialer interface upon
!--- which a virtual-access interface is cloned.

!
interface Dialer1
ip address negotiated
ip mtu 1492

!--- Ethernet MTU default = 1500 (1492 + PPPoE headers = 1500)

ip nat outside
encapsulation ppp
dialer pool 1

!--- Ties to atm interface.

ppp authentication chap callin
ppp chap hostname
ppp chap password
!

!--- The ISP will instruct you regarding
!--- the type of authentication to use.
!--- To change from PPP CHAP to PPP PAP,
!--- replace the following three lines:
!--- ppp authentication chap callin
!--- ppp chap hostname
!--- ppp chap password
!--- with the following two lines:
!--- ppp authentication pap callin
!--- ppp pap sent-username password


!--- For NAT we are going to overload on the Dialer1
!--- interface and add a default route out
!--- since dialer ip address can change.

ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
!
access-list 1 permit 10.92.1.0 0.0.0.255

阅读(6665) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~