ROS是一个不错的软件路由,操用也比较方便,先备份几个script
1.端口映射-gams
/ ip firewall nat add chain=dstnat dst-address=(XXX.XXX.XXX.XXX) protocol=tcp dst-port=2008 to-addresses=(192.168.0.252) to-ports=2000 action=dst-nat comment="anywhere"
2.禁止外网PING
/ ip firewall filter add chain=input src-address=!192.168.0.0/24 protocol=icmp action=drop comment="No wan Ping"
3.排除PCQ
/ ip firewall mangle
add chain=prerouting src-address=192.168.0.228 action=mark-connection \
new-connection-mark=nopcqlimit passthrough=yes comment="" disabled=no
add chain=prerouting src-address=192.168.0.252 action=mark-connection \
new-connection-mark=nopcqlimit passthrough=yes comment="" disabled=no
add chain=prerouting src-address=192.168.0.249 action=mark-connection \
new-connection-mark=nopcqlimit passthrough=yes comment="" disabled=no
add chain=prerouting src-address=192.168.0.100 action=mark-connection \
new-connection-mark=nopcqlimit passthrough=yes comment="" disabled=no
add chain=prerouting connection-mark=nopcqlimit action=accept comment="" \
disabled=no
4.ARP绑定
:foreach i in=[/ip arp find dynamic=yes ] do=[/ip arp add copy-from=$i]
补充:完了在interfaces里面选择内网在选择reply-only 意思就是不可学习,白了就是没绑定MAC的机器上不了网。
5.ARP解绑
:foreach i in [/ip arp find] do={/ip arp remove $i}
6.BT限速
:for aaa from 1 to 100 do={/queue simple add name=(BT . $aaa) target-addresses=(192.168.0. . $aaa) interface=all max-limit=512000/256000 p2p=all-p2p }
7.IP限速
:for aaa from 1 to 200 do={/queue simple add name=(XQ . $aaa) dst-address=(192.168.0. . $aaa) interface=all max-limit=1024000/1024000 burst-limit=2048000/2048000 burst-threshold=500000/500000 burst-time=10s/10s }
这里详细说明下:
(for aaa from 1 to 200 do 和192.168.0. . $aaa)1 to 200和192.168.0..是关系的,1 to 200就是192.168.0.1-192.168.0.200的意思了。
name=(XQ . $aaa) 这个是规则名修改只改XQ这个
max-limit------我们最常用的地方,最大速度
burst-limit--------突破速度的最大值
burst-thershold--------突破速度的阀值
burst-time-------突破速度的时间值
当客户机在10秒(burst-time)内的平均值小于突破速度阀值(burst-thershold)500K时,客户机的最大下载速率可以超过最大限速值(max-limit)1024K,达到突破最大值(burst-limit)2048K,如果10秒内平均值大于500K,那客户机的最大速度只能达到1024K。
这样也就是当我们开网页时可以得到一个更大的速度2048K,长时间下载时速度只能得到1024K,使我们的带宽可以更有效的利用
这里补充下,各个网吧不同 带宽不同 情况不同需要做相应调整,一直调整到感觉不错为止
8.pcqoff
/queue tree disable pcqdown
/queue tree disable pcqup
9.pcqon
/queue tree enable pcqdown
/queue tree enable pcqup
10.关于mac地址扫描 (便于绑定
/tool mac-scan all
限速脚本:
:for aaa from 2 to 254 do={/queue simple add name=(queue . $aaa) dst-address=(192.168.100. . $aaa) limit-at=0/0 max-limit=2000000/2000000}
ARP集体绑定:
:foreach i in=[/ip arp find dynamic=yes ] do={/ip arp add copy-from=$i}
几个非常不错的script.
阅读(2229) | 评论(0) | 转发(0) |