Chinaunix首页 | 论坛 | 博客
  • 博客访问: 9072
  • 博文数量: 2
  • 博客积分: 0
  • 博客等级: 民兵
  • 技术积分: 10
  • 用 户 组: 普通用户
  • 注册时间: 2013-04-18 21:57
文章分类
文章存档

2014年(2)

我的朋友

分类: LINUX

2014-02-27 23:32:12

    有时候在编译和安装软件的时候,经常要使用不同版本的GCC编译器,就需要我们安装多种不同的编译器。
    在Fedora 10的系统中的版本是gcc-4.3.2, 安装在/usr/bin下面,名称是gcc,查看gcc的版本详细信息,可以用命令:
gcc -v查看,由于我要安装MPlayer,下载的源码包(tar.bz2),用gcc-4.3.2编译出错,需要3.1~3.5的版本才能编译,所以
我下载gcc-3.4.5的版本。
    安装完gcc-3.4.5后,在user/local下多一个gcc-3.4.5,这就是刚才的安装的编译器。下一不就是将gcc设置为版本gcc-3.4.5,
将原先的gcc-4.3.2版本备份,就是在user/bin下将gcc更改为gcc-4.3.2bak即可(不要删除,以便以后使用),然后ln -s gcc-4.1 gcc
命令创建一个gcc-3.4.5的连接。这就安装完成了gcc-3.4.5的编译器。
    最后我们可以使用gcc -v看看,版本已经是我们想要的3.4.5了。^_^
阅读(2350) | 评论(0) | 转发(0) |
0

上一篇:Linux shell脚本全面学习

下一篇:没有了

给主人留下些什么吧!~~