Chinaunix首页 | 论坛 | 博客
  • 博客访问: 19999
  • 博文数量: 9
  • 博客积分: 28
  • 博客等级: 民兵
  • 技术积分: 55
  • 用 户 组: 普通用户
  • 注册时间: 2012-03-06 14:53
文章分类

全部博文(9)

文章存档

2012年(9)

我的朋友
最近访客

分类:

2012-11-28 22:19:20

1.安装eclipse:
第一种是通过Ubuntu自带的程序安装功能安装Eclipse,应用程序 ->Ubtuntu软件中心,搜Eclipse安装即可。
第二种方法是用命令:应用程序->附件->终端 然后输入(中间可能需要你输入密码):
sudo apt-get install eclipse
sudo apt-get install eclipse-pde
sudo apt-get install eclipse-jdt
2.安装中文语言包
菜单栏:Help------>Install New Software------>在Work with的框框下输入以下地址回车。
http://download.eclipse.org/technology/babel/update-site/galileo
选择简体中文: Babel Language Packs in Chinese (Simplified)
然后就是选择简体中文安图提示一步步安装
3.安装CDT(c/c++插件)
(1)同 2 中 在Work with的框框下输入 http://download.eclipse.org/releases/galileo
选择Collaboration->Mylyn Bridge: C/C++ Development,安装,重启eclipse
(2)同上输入网址后选择 Programming Languages->Eclipse C/C++ Development
切记:(1)(2)顺序有依赖关系,安装顺序不能颠倒。
在安装cdt的时候,会报这个错误:
An error occurred while installing the items
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]org.eclipse.cvs 1.0.400.v201002111343, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
The artifact file for osgi.bundle,org.eclipse.cvs,1.0.400.v201002111343 was not found.
后来google了一下,发现解决办法。
sudo apt-get install eclipse-pde
在装cdt插件,完成~
用Eclipse+CDT开发c/c++项目的时候,怎么能让Eclipse发挥代码自动提示的功能呢?其实也很简单:
打开终端:输入:$ gcc -version
得到类似的:gcc 版本 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
很容易就看到你当前使用的版本了。
启动Eclipse.进入:Windows-->Preferences-->C/C++找到Environment。增加两个变量:
CPLUS_INCLUDE_PATH: /usr/include/c++/4.1.3(我的gcc版本)
C_INCLUDE_PATH: /usr/include
接下来新建一个c project.编写代码的时候,当敲入'.'的时候就会自动弹出可备用的代码。
阅读(470) | 评论(0) | 转发(0) |
0

上一篇:PHP设计模式笔记:使用PHP实现装饰模式

下一篇:没有了

给主人留下些什么吧!~~