Chinaunix首页 | 论坛 | 博客
  • 博客访问: 346766
  • 博文数量: 80
  • 博客积分: 1750
  • 博客等级: 上尉
  • 技术积分: 1380
  • 用 户 组: 普通用户
  • 注册时间: 2011-11-13 11:35
文章分类
文章存档

2014年(3)

2013年(1)

2012年(54)

2011年(22)

分类:

2011-11-18 10:25:20

2008年 RedHat 收购 Qumranet 以后就一直在家搞他的 KVM,没有对 Xen 做任何升级,RHEL/CentOS 5.5 上默认的 Xen 依旧是很老很老的公元2007年发布的 Xen 3.1.2 版本。更糟糕的是 RedHat 在后续的 RedHat Enterprise Linux 6 里彻底放弃了 Xen. 如果以后想在新版本的 RHEL/CentOS 上用 Xen 的话就需要使用第三方源或者自己动手编译 Xen 源代码。自己编译源代码问题多多,所以没有特殊要求的话,还是建议直接使用第三方源。

shell 代码:

  1.    1. # cd /etc/yum.repos.d/
  2.    2. # wget http://www.gitco.de/repo/GITCO-XEN4.1.1_x86_64.repo
  3.    3. # yum update
  4.    4. # reboot

如果上面的 yum update 没问题的话重启系统就可以了进入 xen 4.1.1 了,如果有问题导致一些依赖需要解决的话可以彻底删除 xen 后重新升级安装:

shell 代码:

  1.    1. # yum groupremove Virtualization
  2.    2. # yum groupinstall Virtualization
  3.    3. # reboot

在重启之前最好检查一下 grub 是否配置正确、默认启动是否是 xen.gz-4.1.1:

shell 代码:

  1.    1. # vi /boot/grub/menu.lst
  2.    2. ...
  3.    3. title CentOS (2.6.18-194.26.1.el5xen)
  4.    4. root (hd0,0)
  5.    5. kernel /xen.gz-4.1.1
  6.    6. module /vmlinuz-2.6.18-194.26.1.el5xen ro root=LABEL=/
  7.    7. module /initrd-2.6.18-194.26.1.el5xen.img
  8.    8. ...
到此就OK 了~~

阅读(580) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~