/dev/data1lv 13107200 10559980 20% 2735 1% /data1
4、确认系统结构
localhost> /usr/bin/getconf HARDWARE_BITMODE
64
5、我们可以通过下面的命令来确认系统CPU个数和主频:
# lsdev -C |grep proc
proc0 Available 00-00 Processor
proc1 Available 00-01 Processor
# lsattr -E -l proc0
frequency 752010000 Processor Speed False
state enable Processor state False
type PowerPC_RS64-III Processor type False
# lsattr -E -l proc1
frequency 752010000 Processor Speed False
state enable Processor state False
type PowerPC_RS64-III Processor type False
二、确认系统软件环境
1、要求AIX必须是5.2 LEVEL 1以上(含LEVEL 1):
localhost> oslevel -r
5200-01
2、要求安装了这些FILESETS:
localhost> lslpp -l bos.adt.base bos.adt.lib bos.adt.libm
bos.perf.perfstat bos.perf.libperfstat bos.perf.proctools
Fileset Level State Description
----------------------------------------------------------------------------
Path: /usr/lib/objrepos
bos.adt.base 5.2.0.11 APPLIED Base Application Development
Toolkit
bos.adt.lib 5.2.0.10 APPLIED Base Application Development
Libraries
bos.adt.libm 5.2.0.13 APPLIED Base Application Development
Math Library
bos.perf.libperfstat 5.2.0.12 APPLIED Performance Statistics Library
Interface
bos.perf.perfstat 5.2.0.12 APPLIED Performance Statistics
Interface
Path: /etc/objrepos
bos.perf.perfstat 5.2.0.0 COMMITTED Performance Statistics
Interface
lslpp: 0504-132 Fileset bos.perf.proctools not installed.
可以看到bos.perf.proctools没有安装,用smitty安装上即可。现在查看确认:
localhost> lslpp -l bos.perf.proctools
Fileset Level State Description
----------------------------------------------------------------------------
Path: /usr/lib/objrepos
bos.perf.proctools 5.2.0.11 APPLIED Proc Filesystem Tools
3、要求安装了APARs(Authorized Problem Analysis Reports):
localhost> /usr/sbin/instfix -i -k "IY43980 IY44810 IY45462 IY45707
IY46214 IY46605 IY48525 IY51801"
All filesets for IY43980 were found.
All filesets for IY44810 were found.
All filesets for IY45462 were found.
All filesets for IY45707 were found.
All filesets for IY46214 were found.
All filesets for IY46605 were found.
There was no data for IY48525 in the fix database.
There was no data for IY51801 in the fix database.
可以看到IY48525和IY51801没有安装,我们可以从网上下载它们然后安装上,这里是下载地址:
但实际上,这两个补丁是针对SDK1.4的, 如果不用1.4完全可以不理。
4、创建Oracle10g用户和组,并创建相关目录(这一步是最关键的)
注意哦,认真操作每一个步骤哦 ^-^ ^-^ ^-^ ^-^ ^-^
useradd - g oinstall –G dba –d /home/oracle –s /usr/bin/bash –m oracle
passwd oracle
完成以后:用oracle用户进行登陆修改 .profile
su - oracle
4.1.设置系统环境变量:(一般情况是在/HOME/ORACLE)
编辑操作系统profile文件,将上输的oracle_home,oracle_sid等写上就行了
ORACLE_HOME=/home/oracle/product/10.2.0
ORACLE_BASE=/home/oracle
4.2.系统规划:(这里用TEST)
实例名称ORACLE_SID=test
数据库名称:test
4.3.手工创建如下目录:
/home/oracle/admin/test/cdump
/home/oracle/admin/test/bdump
/home/oracle/admin/test/udump
/home/oracle/admin/test/pfile
/home/oracle/oradata/test
附:我的.profile文件
if [ -s "$MAIL" ] # This is at Shell startup. In normal
then echo "$MAILMSG" # operation, the Shell checks
fi # periodically.
# .bash_profile
# Get the aliases and functions
if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi
# User specific environment and startup programs
ORACLE_HOME=/home/oracle/product/10.2.0;
export ORACLE_HOME
export ORACLE_BASE=/home/oracle
export ORACLE_SID=test
unset USERNAME
umask 022
PATH=$PATH:$HOME/bin:$ORACLE_HOME/bin;
export PATH
5 . 编辑Response 文件
这一步骤是字符界面装oracle的关键步骤
到oracle 10g的安装目录下编辑response文件
$su – oracle
$cd /$HOME/$ID/Disk1/response
可以看到oracle准备了6个response文件,实际上这些文件就是用来安装和配置oracle时的模板,分别是
custom.rsp dbca.rsp emca.rsp enterprise.rsp netca.rsp standard.rsp在这里挑了一
个简单的response文件 enterprise.rsp,也可以根据实际情况去选用编辑其他几个response文件。
$cp custom.rsp myinst.rsp
$vi myinst.rsp
在myinst.rsp的最前面有一段说明,应该仔细看看,特别要注意它定义的几个数据变量格式的写法,如下:
Type Example
String "Sample Value"
Boolean True or False
Number 1000
StringList {"String value 1","String Value 2"}