Chinaunix首页 | 论坛 | 博客
  • 博客访问: 5859802
  • 博文数量: 162
  • 博客积分: 3600
  • 博客等级: 中校
  • 技术积分: 10362
  • 用 户 组: 普通用户
  • 注册时间: 2011-01-19 11:23
个人简介

专注系统运维、网络架构,研究技术解决方案,记录我的思想轨迹、工作学习、生活和关注的领域

文章分类
文章存档

2014年(2)

2013年(16)

2012年(27)

2011年(117)

分类: 系统运维

2011-10-24 14:54:01

Zend Optimizer 主要有两个功能:

1、可以加速 PHP 脚本的执行;

2、可以给用 Zend 加密的文件解密。

所以,一般来说,如果 PHP 脚本没有经过加密,可以不必安装 Zend Optimizer 。

目前我们的产品中包含加密文件的产品有:SupeSite、SupeV、UCenter Home1.0,因此,如果您需要安装这些产品,那么需要在搭建环境时成功安装 Zend Optimizer。对于论坛来说,如果你想使用支付宝、奇虎搜索,也需要安装 Zend Optimizer。对于商城 ECShop,如果您需要转码,也需要系统支持 Zend Optimizer。

下面详细介绍下如何判断系统是否支持 Zend Optimizer :

一、首先写一个 phpinfo 文件,代码如下:

保存代码为 PHP 文件,如 phpinfo.php,然后将该文件放到网站根目录下。

二、输入http://您的站点网址/phpinfo.php,如果安装了 Zend Optimizer,应该可以看到如下图所示:

注意图中紫色突出的部分是 Zend Optimizer,这说明您已经正确安装了 Zend Optimizer,而不是 Zend 或其他标志。

如果您的系统不支持 Zend Optimizer,则可能出现以下情况:

1、安装的产品有加密过的文件时,可能出现空白等问题导致安装不成功。

2、不能使用支付宝、奇虎搜索等有加密文件的功能。

3、商城 ECShop 不能实现转码。

阅读(5388) | 评论(0) | 转发(3) |
给主人留下些什么吧!~~