Chinaunix首页 | 论坛 | 博客
  • 博客访问: 1209302
  • 博文数量: 247
  • 博客积分: 5587
  • 博客等级: 大校
  • 技术积分: 2060
  • 用 户 组: 普通用户
  • 注册时间: 2010-02-24 13:27
文章分类
文章存档

2012年(101)

2011年(44)

2010年(102)

分类: 嵌入式

2011-11-24 10:19:45

上述代码报错如下

- implements android.view.View.OnClickListener.onClick
- The method onClick(View) of type new View.OnClickListener(){} must override a superclass




查找后发现是jdk版本问题 项目属性---->javaCompiler中的complier compliance level 将1.5改为1.6就是说Java 1.5的编译器默认对父类的方法进行覆盖,采用@Override进行说明;但1.6已经扩展到对接口的方法;所以如果还是以Java 1.5的编译器来编译的话,会出现错误。java的编译器是1.6版本的,选择编译级别为1.6,但重要的一点是,选择build的android库是 1.5的即可,生成的apk程序是可以在1.5内核上跑起来。总的来讲: android sdk的版本与Java JRE的版本可以配置起来用,两者关系应该是疏松的。
阅读(915) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~