Chinaunix首页 | 论坛 | 博客
  • 博客访问: 500498
  • 博文数量: 196
  • 博客积分: 115
  • 博客等级: 民兵
  • 技术积分: 364
  • 用 户 组: 普通用户
  • 注册时间: 2010-05-13 23:19
文章分类

全部博文(196)

文章存档

2019年(5)

2018年(11)

2017年(16)

2016年(13)

2015年(46)

2014年(81)

2013年(22)

2012年(2)

分类: 网络与安全

2016-03-25 16:00:59

    由于Kali在虚拟机的运行效率实在让人不敢恭维,于是决心将BT5中的MSF进行升级,升级的主要目的是,BT5R3内置的MSF是用SVN进行更新,但是新版本的MSF已经停止通过SVN更新,改用Git,必须重新安装。网上找了很多办法,看见帖子里明明升级成功,但是自己总是不成功,卡在pg (0.15.0)无法成功安装,个人认为的原因是MSF并没有用BT5内置的RUBY,而是利用自带的RUBY,其自带的版本为1.9.1,已经很古老了……所以升级系统的Ruby版本也会无济于事,但是按照下面的步骤更新,即可将MSF更新至最新,且在运行msfupdate时,利用的是Git更新系统了。
    1、apt-get update
    2、apt-get install metasploit
    3、修改文件:/opt/metasploit/ruby/lib/ruby/1.9.1/i686-linux/rbconfig.rb
         changed the line => CONFIG["LIBRUBYARG_STATIC"] = "-Wl,-R -Wl,$(libdir) -L$(libdir) -l$(RUBY_SO_NAME)-static" by => CONFIG["LIBRUBYARG_STATIC"] = "-Wl,-R -Wl,$(libdir) -L$(libdir) "(其实就是去掉-l$(RUBY_SO_NAME)-static)
    4、切换至/opt/metasploit/msf3然后运行/opt/metasploit/ruby/bin/bundle install
    5、msfupdate
    实测,完美通过,不会再卡在pg (0.15.0)无法成功安装那里。
   

阅读(1136) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~
评论热议
请登录后评论。

登录 注册