Chinaunix首页 | 论坛 | 博客
  • 博客访问: 343073
  • 博文数量: 122
  • 博客积分: 5000
  • 博客等级: 大校
  • 技术积分: 1191
  • 用 户 组: 普通用户
  • 注册时间: 2009-10-24 11:12
文章分类

全部博文(122)

文章存档

2010年(122)

我的朋友

分类: C/C++

2010-04-21 16:52:33

一、问题描述

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9

1 2

1 3

1 4

1 5

1 6

1 7

1 8

1 9

1 10

10 4

2 3

4 5

4 8

5 8

0 0

Sample Output

Case 1: 1

Case 2: 7

Hint

Huge input, scanf is recommended.

二、解题思路

使用并查集数据结构。

三、代码

#include<iostream>
bool exist[50005];
int p[50005];
int r[50005];
//初始化并查集

void MakeSet(int n)
{
    for(int i=1;i<=n;++i)
    {
        p[i]=i;//每个元素的父亲初始为它自己

        r[i]=0;//用于路径压缩

    }
}
//查找x的父亲,即查找x属于哪个集合

int FindSet(int x)
{
    if(x!=p[x])
        p[x]=FindSet(p[x]);
    return p[x];
}
//将集合x与集合y进行合并

void Link(int x,int y)
{
    if(r[x]>r[y])
        p[y]=x;
    else
        p[x]=y;
    if(r[x]==r[y])
        r[y]=r[y]+1;
}
//将x所在集合与y所在集合进行合并

void Union(int x,int y)
{
    int m=FindSet(x);
    int n=FindSet(y);
    if(m!=n)
        Link(m,n);
}
int main()
{
    int n,m;
    int a,b;
    int i;
    int c=1;
    while(scanf("%d%d",&n,&m))
    {
        if(n==0 && m==0)
            break;
        MakeSet(n);
        for(i=0;i<m;++i)
        {
            scanf("%d%d",&a,&b);
            Union(a,b);
        }
        memset(exist,0,sizeof(exist));
        int sum=0;
        for(i=1;i<=n;++i)
        {
            int t=FindSet(i);
            if(exist[t]==false)
            {
                sum ++;
                exist[t]=true;
            }
        }
        printf("Case %d: %d\n",c,sum);
        c++;
    }
    return 0;
}


阅读(834) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~