Chinaunix首页 | 论坛 | 博客
  • 博客访问: 343107
  • 博文数量: 122
  • 博客积分: 5000
  • 博客等级: 大校
  • 技术积分: 1191
  • 用 户 组: 普通用户
  • 注册时间: 2009-10-24 11:12
文章分类

全部博文(122)

文章存档

2010年(122)

我的朋友

分类: C/C++

2010-04-02 14:44:33

一、问题描述

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output:
Test case (case number): (number of crossings)

Sample Input

1

3 4 4

1 4

2 3

3 2

3 1

Sample Output

Test case 1: 5

二、解题思路

     使用树状数组。将输入看成是x,y。将输入数据按y从小到大排序,如果y相等,则按x从小到大排序。从头到尾遍历一次,用树状数组维护到各城市的道路数量,同时用s统计交叉点数。

三、代码

 

#include<algorithm>
using namespace std;
struct Pos
{
    int x;
    int y;
};
int cmp(const void * a,const void *b)
{
    Pos *c =(Pos *)a;
    Pos *d= (Pos *)b;
    if(c->y == d->y)
        return c->x - d->x;
    else
        return c->y - d->y;
}
Pos p[1000001];
int C[1001];
int n;
int Lowbit(int x)
{
    return x&(x^(x-1));
}
void Modify(int i,int x)
{
    while(i<=n)
    {
        C[i]+=x;
        i+=Lowbit(i);
    }
}
int Sum(int i)
{
    int sum=0;
    while(i>0)
    {
        sum+=C[i];
        i-=Lowbit(i);
    }
    return sum;
}
int main()
{
    int T;
    int i,t;
    int M,N,K;
    int xMax;
    scanf("%d",&T);
    for(t=1;t<=T;++t)
    {
        memset(C,0,sizeof(C));
        scanf("%d%d%d",&M,&N,&K);
        xMax=0;
        for(i=0;i<K;++i)
        {
            scanf("%d%d",&p[i].x,&p[i].y);
            if(xMax< p[i].x)
                xMax=p[i].x;
        }
        n=xMax;
        qsort(p,K,sizeof(p[0]),cmp);
        __int64 s=0;
        for(i=0;i<K;++i)
        {
            s+=(Sum(xMax)-Sum(p[i].x));
            Modify(p[i].x,1);
        }
        printf("Test case %d: %I64d\n",t,s);

    }
    return 0;
}


阅读(728) | 评论(2) | 转发(0) |
给主人留下些什么吧!~~

chinaunix网友2010-10-25 14:35:10

楼上有更好的方法?

chinaunix网友2010-10-25 13:51:08

你不嫌累啊!装B招雷劈。。