Chinaunix首页 | 论坛 | 博客
  • 博客访问: 343595
  • 博文数量: 122
  • 博客积分: 5000
  • 博客等级: 大校
  • 技术积分: 1191
  • 用 户 组: 普通用户
  • 注册时间: 2009-10-24 11:12
文章分类

全部博文(122)

文章存档

2010年(122)

我的朋友

分类: C/C++

2010-03-16 21:31:10

 

资源来源:http://blog.chinaunix.net/u3/105033/index.html

 

一、问题描述

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3

2 2 4 3 5

2 1 2 3 6

2 1 2 2 2

5

3 4 4 2 8 5 3

1 5 8

4 1 6 4 10 2 7 5 2

0

2 2 5 1 5

0

Sample Output

3 2

3 10

 

二、解题思路

先用Floyd算法求出所有点之间的最短距离,然后计算b[i]=Max(a[i][j])(1<=j<=n),数组b中的最小值便是最短时间,所对应的下标i为开始的那个人。

三、代码

 

 

#include<iostream>
using namespace std;
int a[101][101];
const int iMax=0xffff;
void Init(int n)
{
    for(int i=1;i<=n;++i)
    {
        for(int j=1;j<=n;++j)
        {
            if(i!=j)
                a[i][j]=iMax;
            else
                a[i][j]=0;
        }
    }
}
void AllLength(int n)
{
    int i,j,k;
    for(k=1;k<=n;++k)
    {
        for(i=1;i<=n;++i)
        {
            for(j=1;j<=n;++j)
            {
                if(a[i][k]+a[k][j]<a[i][j])
                {
                    a[i][j]=a[i][k]+a[k][j];
                }
            }
        }
    }
}
int main()
{
    int n;
    int i,j,k;
    int c,p,t;
    cin>>n;
    while(n!=0)
    {
        Init(n);
        for(i=1;i<=n;++i)
        {
            cin>>c;
            for(k=0;k<c;++k)
            {
                cin>>p>>t;
                a[i][p]=t;
            }
        }
        AllLength(n);
        int start;
        int time=iMax;
        for(j=1;j<=n;++j)
        {
            int rMax=0;
            for(k=1;k<=n;++k)
            {
                if(rMax<a[j][k])
                    rMax=a[j][k];
            }
            if(time>rMax)
            {
                time=rMax;
                start=j;
            }
        }
        if(time==iMax)
             cout<<"disjoint"<<endl;
        else
            cout<<start<<" "<<time<<endl;
        cin>>n;
    }
    return 0;
}


阅读(947) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~